X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

With Firefox 6, the "x" in the tab (to close it) is no longer there. One click to close has now gone to 2 clicks (right click then close). Am I missing something?

Veröffentlicht

Nothing to add

Nothing to add

Ausgewählte Lösung

So I had this problem when I upgraded to 6, and I was able to "repopulate" them by going to Options > Tabs. The thing was, I didn't toggle any flags. When I exited the Options menu, the "x" option in tabs magically appeared. Seems to be a small bug.

Diese Antwort im Kontext lesen 1

Mehr Details zum System

Das passierte

Immer wenn Firefox geöffnet wird

Das begann, als…

with the vers 6 release

Installierte Plugins

  • Foxit Reader Plug-In For Firefox and Netscape
  • Google Talk Plugin Video Accelerator version:0.1.44.5
  • Version 2.1.8.0
  • np-mswmp
  • npdivxplayerplugin
  • Winamp Application Detector
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 10.3 r181
  • DivX Web Player version 2.1.1.94
  • DivX VOD Helper Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0

Weitere Informationen

soulz22 1 Lösungen 1 Antworten
Veröffentlicht

Ausgewählte Lösung

So I had this problem when I upgraded to 6, and I was able to "repopulate" them by going to Options > Tabs. The thing was, I didn't toggle any flags. When I exited the Options menu, the "x" option in tabs magically appeared. Seems to be a small bug.

So I had this problem when I upgraded to 6, and I was able to "repopulate" them by going to Options > Tabs. The thing was, I didn't toggle any flags. When I exited the Options menu, the "x" option in tabs magically appeared. Seems to be a small bug.

Fragesteller

That got it. Tks.

BTW, the X did show one time b4 I originally posted this issue. But then it disappeared and didn't reappear. This time apparently it stays put :)

Tks again.

That got it. Tks. BTW, the X did show one time b4 I originally posted this issue. But then it disappeared and didn't reappear. This time apparently it stays put :) Tks again.
rgw1024 0 Lösungen 3 Antworten
Veröffentlicht

The Option Tabs trick did not work for me. The X's do reappear if I open 3 or more tabs and then close one with 'right click close'. However, if I then close all but one tab, the X's disappear and I have to repeat the open 3, right click close to get them back.

The Option Tabs trick did not work for me. The X's do reappear if I open 3 or more tabs and then close one with 'right click close'. However, if I then close all but one tab, the X's disappear and I have to repeat the open 3, right click close to get them back.

Fragesteller

One thing I did do but didn't mention: I changed a selection--> I put a check in the "When I open a link in a new tab , go to it immediately".

Closed the options dialogue box, closed FF and restarted FF.

I always get the "x" now.

One thing I did do but didn't mention: I changed a selection--> I put a check in the "When I open a link in a new tab , go to it immediately". Closed the options dialogue box, closed FF and restarted FF. I always get the "x" now.
pchimbolo 0 Lösungen 2 Antworten
Veröffentlicht

Hilfreiche Antwort

Changing the Tab options and restarting FF doesn't work for me. This is nothing but a bug that simply needs fixing.

Changing the Tab options and restarting FF doesn't work for me. This is nothing but a bug that simply needs fixing.
pchimbolo 0 Lösungen 2 Antworten
Veröffentlicht

Here's a workaround that brings back the "X" (for now, until we see a real fix):

1. Make sure you have at least 3 tabs open (no need to load a page, those extra tabs can be empty)

2. Once you've got 3 or more tabs open... right-click on any tab other than the first one and select "Close Tab"

Yes, the "X" will now appear on the other tabs, and any new tabs you open. However, it's only good: (a) if you KEEP OPEN 2 or more tabs and (b) for that browser session. Once you close all but one tab, or close FF and open it again... you no longer have the "X".

Silly bug!

Here's a workaround that brings back the "X" (for now, until we see a real fix): 1. Make sure you have at least 3 tabs open (no need to load a page, those extra tabs can be empty) 2. Once you've got 3 or more tabs open... right-click on any tab '''other than''' the first one and select "Close Tab" Yes, the "X" will now appear on the other tabs, and any new tabs you open. However, it's only good: (a) if you KEEP OPEN 2 or more tabs and (b) for that browser session. Once you close all but one tab, or close FF and open it again... you no longer have the "X". Silly bug!

Geändert am von pchimbolo

rgw1024 0 Lösungen 3 Antworten
Veröffentlicht

Thanks! That does work for me.

Still no X if only one tab is open. Opera and IE9 have X even if only one tab is open. In IE9, clicking on the X with only one tab will close IE9 altogether while Opera closes that tab and returns to Speed Dial tab. Personally, I like Opera's style best. FF6 does not allow the single tab to be closed, so the closest thing to approximate Opera is to open a tab to your home page (or a blank page), right click and "Pin as App Tab". This minimizes the tab width and if you only pin one tab, you can close all the rest and return to the page you've pinned. But you have to do this each time you open FF6, so it's still not very user friendly!

Thanks! That does work for me. Still no X if only one tab is open. Opera and IE9 have X even if only one tab is open. In IE9, clicking on the X with only one tab will close IE9 altogether while Opera closes that tab and returns to Speed Dial tab. Personally, I like Opera's style best. FF6 does not allow the single tab to be closed, so the closest thing to approximate Opera is to open a tab to your home page (or a blank page), right click and "Pin as App Tab". This minimizes the tab width and if you only pin one tab, you can close all the rest and return to the page you've pinned. But you have to do this each time you open FF6, so it's still not very user friendly!
oggologgo 0 Lösungen 7 Antworten
Veröffentlicht

Hilfreiche Antwort

This is a bug, since version 6.

I randomly disappears, and then randomly comes back.

This is a bug, since version 6. I randomly disappears, and then randomly comes back.
storkfmny 0 Lösungen 4 Antworten
Veröffentlicht

I had the same problem. All I did was close the browser completely and restart it and all my tab x's were restored. I even restored the previous browsing session and all the x's were there this time.

I had the same problem. All I did was close the browser completely and restart it and all my tab x's were restored. I even restored the previous browsing session and all the x's were there this time.
RonQ 0 Lösungen 80 Antworten
Veröffentlicht

Another bug.

Great. More bugs foisted upon the users because Mozilla couldn't take its time to get them ironed out in beta before making it a scheduled update.

Mozilla should have ironed out the problems with 4.x before moving to a new, buggy 5.x then a new, buggy 6.x

Another bug. Great. More bugs foisted upon the users because Mozilla couldn't take its time to get them ironed out in beta before making it a scheduled update. Mozilla should have ironed out the problems with 4.x before moving to a new, buggy 5.x then a new, buggy 6.x