X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Windows not showing. Page source and library windows open but not showing.

Veröffentlicht

I select View --> Page Source and no window appears. Under the Window menu, the item Source: . . . shows but no window. If I close the main window then the item is ticked but still no actual window. I have disable all extensions and plugins, safe mode, revert all preferences. the same happens with Show all Bookmarks. This is why I posted this under bookmarks problems originally - see below. I now find the same happens to downloads and Error console windows. No problems in Safari or MS Word (usually the worst performer)

Bookmarks are all present, but show all bookmarks produces no window, even though the window menu shows an item and I can select it. Mac OS 10.6.8 FF 5.01 Show all bookmarks shows no window, even if I close the main window. Under window menu the 'Library' item is ticked but still nothing. I have restarted, and renamed places database. recently installed some of these addons

I select View --> Page Source and no window appears. Under the Window menu, the item Source: . . . shows but no window. If I close the main window then the item is ticked but still no actual window. I have disable all extensions and plugins, safe mode, revert all preferences. the same happens with Show all Bookmarks. This is why I posted this under bookmarks problems originally - see below. I now find the same happens to downloads and Error console windows. No problems in Safari or MS Word (usually the worst performer) Bookmarks are all present, but show all bookmarks produces no window, even though the window menu shows an item and I can select it. Mac OS 10.6.8 FF 5.01 Show all bookmarks shows no window, even if I close the main window. Under window menu the 'Library' item is ticked but still nothing. I have restarted, and renamed places database. recently installed some of these addons

Geändert am von mikejn1@btinternet.com

Mehr Details zum System

Das passierte

Immer wenn Firefox geöffnet wird

Das begann, als…

I installed extensions, but they are all disabled now

Installierte Plugins

All disabled

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

Weitere Informationen

Application Basics
Name
Firefox
Version
5.0.1
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
British English Dictionary
1.19.1
false
en-GB@dictionaries.addons.mozilla.org
DOM Inspector
2.0.10
false
inspector@mozilla.org
DownThemAll!
2.0.7
false
{DDC359D1-844A-42a7-9AA1-88A850A938A8}
EndNote Web
3.1.1
false
{322e833a-a7d4-4277-97c6-334fa1622d6a}
Extended Statusbar
1.5.8
false
{daf44bf7-a45e-4450-979c-91cf07434c3d}
Firebug
1.8.0
false
firebug@software.joehewitt.com
Firefox PDF Plugin for Mac OS X
1.1.3
false
colesbury@gmail.com
Firefox Sync
1.7
false
{340c2bbc-ce74-4362-90b5-7c26312808ef}
FireFTP
1.99.4
false
{a7c6cf7f-112c-4500-a7ea-39801a327e5f}
FireSSH
0.87
false
firessh@nightlight.ws
FoxLingo
2.7.2
false
{ef62e1ce-d2a4-4cdd-b7ec-92b120366b66}
FoxyProxy Standard
3.1
false
foxyproxy@eric.h.jung
Google Shortcuts
2.1.6
false
{5C46D283-ABDE-4dce-B83C-08881401921C}
Greasemonkey
0.9.7
false
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
KwiClick
2.7.2.884
false
vinceturk@gmail.com
LinkExtend
1.1.3
false
{cf47767d-5f3a-4e32-9fce-5d79565c9702}
MyBookmarks
0.6.1
false
mybookmarks@ma2ten.catsyawn.net
Nightly Tester Tools
3.1.5.1
false
{8620c15f-30dc-4dba-a131-7c5d20cf4a29}
NoScript
2.1.2.5
false
{73a6fe31-595d-460b-a920-fcc0f8843232}
NoSquint
2.1.2
false
nosquint@urandom.ca
Popup Chinese Dictionary
1.7
false
david.lancashire@gmail.com
Resurrect Pages
2.0.6
false
{0c8fbd76-bdeb-4c52-9b24-d587ce7b9dc3}
SQLite Manager
0.7.5
false
SQLiteManager@mrinalkant.blogspot.com
Stylish
1.2
false
{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}
Web Developer
1.1.9
false
{c45c406e-ab73-11d8-be73-000a95be3b12}
Xmarks
4.0.1
false
foxmarks@kei.com
Zotero
2.1.8
false
zotero@chnm.gmu.edu
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110707182747
browser.startup.homepage_override.mstone
rv:5.0.1
extensions.lastAppVersion
5.0.1
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1312456982
places.history.expiration.transient_current_max_pages
64424
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
0x21900,0x20400
Vendor ID
0000
Device ID
0000
Adapter RAM
Adapter Drivers
Driver Version
Driver Date
Direct2D Enabled
false
DirectWrite Enabled
false
WebGL Renderer
ATI Technologies Inc. -- ATI Radeon X1600 OpenGL Engine -- 2.0 ATI-1.6.36
GPU Accelerated Windows
0/3

David McRitchie 320 Lösungen 3092 Antworten
Veröffentlicht

paste this into the location bar and press "enter" when you have a webpage displayed to see if it will show you the source.

javascript:location="view-source:"+location

If that works you have probably messed up trying to use some editor to view source.

If it doesn't work make sure you have JavaScript turned on, and if off then activate and retest.
paste this into the location bar and press "enter" when you have a webpage displayed to see if it will show you the source. javascript:location="view-source:"+location If that works you have probably messed up trying to use some editor to view source. :If it doesn't work make sure you have JavaScript turned on, and if off then activate and retest.

Fragesteller

When noscript ennabled then your javascript:location="view-source:"+location shows source in same tab, same window. Nothing to do with messed up trying to use some editor since it is not just the source window that doesn't show but the 'show all bookmarks' , the error console, and other windows.

When noscript ennabled then your javascript:location="view-source:"+location shows source in same tab, same window. Nothing to do with messed up trying to use some editor since it is not just the source window that doesn't show but the 'show all bookmarks' , the error console, and other windows.
Hasan 469 Lösungen 5600 Antworten
Veröffentlicht

Corrupt localstore.rdf

Check and tell if its working.

Corrupt localstore.rdf * http://kb.mozillazine.org/Corrupt_localstore.rdf Check and tell if its working.

Fragesteller

I deleted localstore.rdf. No change. Funny thing is before your post I got the windows back briefly. First I was able to select the bookmarks or source window from the window menu, but there was just a thin vertical line - 1 or 2 pixels insted of the window. Then if I selected window zoom, there was the window! Then after editing bookmarks and turning on 'mybookmarks' extension the windows went again. Turned off mybookmarks, only extensions on are NoScript and Google shortcuts. Still same problem. Windows don't appear: library, source, error console, downloads.

I deleted localstore.rdf. No change. Funny thing is before your post I got the windows back briefly. First I was able to select the bookmarks or source window from the window menu, but there was just a thin vertical line - 1 or 2 pixels insted of the window. Then if I selected window zoom, there was the window! Then after editing bookmarks and turning on 'mybookmarks' extension the windows went again. Turned off mybookmarks, only extensions on are NoScript and Google shortcuts. Still same problem. Windows don't appear: library, source, error console, downloads.
Hasan 469 Lösungen 5600 Antworten
Veröffentlicht

Troubleshooting extensions and themes

Check and tell if its working.

Troubleshooting extensions and themes * https://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes Check and tell if its working.

Fragesteller

I had already done that. All extensions off, I always used the basic theme.

I have also found that when I log in as another user, so another profile, this time an admin user, there is no problem. When I right-click on a link and 'open in new window' the same happens - no window, though it appears on the window menu. Open in new tab is fine.

If i drag a tab off the window the same happens, and also if I open a new window, so it is something to do with not being able to show more than one window.

I had already done that. All extensions off, I always used the basic theme. I have also found that when I log in as another user, so another profile, this time an admin user, there is no problem. When I right-click on a link and 'open in new window' the same happens - no window, though it appears on the window menu. Open in new tab is fine. If i drag a tab off the window the same happens, and also if I open a new window, so it is something to do with not being able to show more than one window.

Fragesteller

Curiouser and curiouser. I created a new profile.

Now other windows appear, including 'open link in new window'; source; downloads; error console; but not the show all bookmarks Will try admin profile again.

Curiouser and curiouser. I created a new profile. Now other windows appear, including 'open link in new window'; source; downloads; error console; but not the show all bookmarks Will try admin profile again.
Hasan 469 Lösungen 5600 Antworten
Veröffentlicht

Where can I find my Bookmarks?

Check and tell if its working.

Where can I find my Bookmarks? * https://support.mozilla.com/en-US/kb/how-do-i-use-bookmarks?#w_where-can-i-find-my-bookmarks Check and tell if its working.

Fragesteller

Nothing to check, I have the bookmarks, but it's the windows that were not appearing, then only the library.

Now they are all back, I copied the profile folder from another login and chose that at startup. So something in the profile! SOLVED.

Nothing to check, I have the bookmarks, but it's the windows that were not appearing, then only the library. Now they are all back, I copied the profile folder from another login and chose that at startup. So something in the profile! SOLVED.

Geändert am von mikejn1@btinternet.com

Hasan 469 Lösungen 5600 Antworten
Veröffentlicht

Glad to hear it

Glad to hear it

Geändert am von Hasan

Fragesteller

The one that solved it was my own last post, which does not have a Solved it.

I copied the FF profile folder from another login and started with that. However. . . the problem is back. I installed extensions, NoScript and MyBookmarks and it seemed OK after that.

Then I installed Download Youtube videos + 3.3.51, then DownThemAll! 2.0.7, Google Shortcuts 2.1..6, ImTranslator, QuickWiki and Read It later. No Plugins ennabled.

when I disable all extensions then the windows for downloads, error console and 'open link in new window appear OK, but not the source or Library windows. 

As before they are on the window menu but no way to make them visible.

The one that solved it was my own last post, which does not have a Solved it. I copied the FF profile folder from another login and started with that. However. . . the problem is back. I installed extensions, NoScript and MyBookmarks and it seemed OK after that. Then I installed Download Youtube videos + 3.3.51, then DownThemAll! 2.0.7, Google Shortcuts 2.1..6, ImTranslator, QuickWiki and Read It later. No Plugins ennabled. when I disable all extensions then the windows for downloads, error console and 'open link in new window appear OK, but not the source or Library windows. As before they are on the window menu but no way to make them visible.
Hasan 469 Lösungen 5600 Antworten
Veröffentlicht
Troubleshooting extensions and themes * https://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes Corrupt localstore.rdf * http://kb.mozillazine.org/Corrupt_localstore.rdf Locked or Damaged places.sqlite * http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox Check and tell if its working.

Geändert am von Hasan

TicoDeBladder 0 Lösungen 1 Antworten
Veröffentlicht

I have exact the same problem.

When I open a page (this one for instance) and I select View Source from the context menu, no Source window appears. The name of the Source window does come up in the windows menu and it comes up in the context menu of the Firefox icon in the Dock.

Same thing for the Downloads window, the Bookmarks window, the Page info window (and more?)

OSX 10.7.2, Firefox 7.0.1

I tried starting up in Safe mode to reset toolbars. I also deinstalled all extensions, both with no effect.

I have exact the same problem. When I open a page (this one for instance) and I select View Source from the context menu, no Source window appears. The name of the Source window does come up in the windows menu and it comes up in the context menu of the Firefox icon in the Dock. Same thing for the Downloads window, the Bookmarks window, the Page info window (and more?) OSX 10.7.2, Firefox 7.0.1 I tried starting up in Safe mode to reset toolbars. I also deinstalled all extensions, both with no effect.

Geändert am von TicoDeBladder

cor-el
  • Top 10 Contributor
  • Moderator
17580 Lösungen 159060 Antworten
Veröffentlicht

That can happen if you have a multiple monitor setup and you are not on the first monitor.

That can happen if you have a multiple monitor setup and you are not on the first monitor.