X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Why only for me my webpage is little bit broken?

Veröffentlicht

Why only for me my webpage is little bit broken not showing correctly? With other browsers is OK, but then i using Firefox 4+ version it's little bit broken, my friends using same browser like me, but for they website looking good. Please help me, because i don't like use old firefox versions :/ You can see how for me it look's: http://img818.imageshack.us/img818/8585/unledal.jpg At normally the text from panel's should little bit exposed from panel.

Why only for me my webpage is little bit broken not showing correctly? With other browsers is OK, but then i using Firefox 4+ version it's little bit broken, my friends using same browser like me, but for they website looking good. Please help me, because i don't like use old firefox versions :/ You can see how for me it look's: http://img818.imageshack.us/img818/8585/unledal.jpg At normally the text from panel's should little bit exposed from panel.

Mehr Details zum System

Betroffene Websites

http://sentel.lt/index2.php

Installierte Plugins

  • Google Update
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.6
  • Next Generation Java Plug-in 10.0.0 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • 1.7
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

Weitere Informationen

Application Basics
Name
Firefox
Version
5.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Feedback
1.1.2
true
testpilot@labs.mozilla.com
Firebug
1.7.3
true
firebug@software.joehewitt.com
Greasemonkey
0.9.7
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
Password Exporter
1.2.1
true
{B17C1C5A-04B1-11DB-9804-B622A1EF5492}
Browser Defender Toolbar
3.0.0.312
false
{cb84136f-9c44-433a-9048-c5cd9df1dc16}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://google.lt
browser.startup.homepage_override.buildID
20110707182747
browser.startup.homepage_override.mstone
rv:5.0.1
browser.tabs.warnOnClose
false
extensions.lastAppVersion
5.0.1
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1311847445
places.history.expiration.transient_current_max_pages
104512
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5700 Series
Vendor ID
1002
Device ID
68be
Adapter RAM
1024
Adapter Drivers
aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Driver Version
8.861.0.0
Driver Date
5-24-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7600.16763, font cache n/a)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows
1/1 Direct3D 10

Xircal 334 Lösungen 3835 Antworten
Veröffentlicht

it's difficult to see what you mean from your screenshot.

Could you please post the link to the site and then we can have a look at it.

it's difficult to see what you mean from your screenshot. Could you please post the link to the site and then we can have a look at it.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 Lösungen 40290 Antworten
Veröffentlicht

URL is in more system details - http://sentel.lt/index2.php

Firefox is displaying that page in the Quirks Mode and Firefox 4/0+ versions are less tolerant in Quirks Mode than earlier versions were.

http://validator.w3.org/check?uri=http://sentel.lt/index2.php

URL is in more system details - http://sentel.lt/index2.php Firefox is displaying that page in the Quirks Mode and Firefox 4/0+ versions are less tolerant in Quirks Mode than earlier versions were. http://validator.w3.org/check?uri=http://sentel.lt/index2.php
Xircal 334 Lösungen 3835 Antworten
Veröffentlicht

Time to get a new pair of glasses for me Ed. :P

Time to get a new pair of glasses for me ''Ed''. :P

Fragesteller

What should i do ? Other friends has same version firefox and for them everything working perfect.

What should i do ? Other friends has same version firefox and for them everything working perfect.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 Lösungen 40290 Antworten
Veröffentlicht

Fix your coding so your web pages are displayed in "standards mode" rather then the "quirks mode". The problem with the quirks mode is that it forces Firefox to guess your intentions about how something is to be displayed, when your friends view that page Firefox guesses right, but for you Firefox is guessing wrong. Eliminate the "guess" factor and Firefox should display your web page the same for all users.
http://en.wikipedia.org/wiki/Quirks_Mode

Plus, once you fix the code, maybe you can get rid of that NO IE logo that appears when someone uses IE to view that page. Times are changing, IE 8 and even more so IE9, can display web pages almost as good as Firefox, Opera, and Chrome, and if not the web page is more than likely at fault.

Fix your coding so your web pages are displayed in "standards mode" rather then the "quirks mode". The problem with the quirks mode is that it forces Firefox to guess your intentions about how something is to be displayed, when your friends view that page Firefox guesses right, but for you Firefox is guessing wrong. Eliminate the "guess" factor and Firefox should display your web page the same for all users. <br /> http://en.wikipedia.org/wiki/Quirks_Mode Plus, once you fix the code, maybe you can get rid of that NO IE logo that appears when someone uses IE to view that page. Times are changing, IE 8 and even more so IE9, can display web pages almost as good as Firefox, Opera, and Chrome, and if not the web page is more than likely at fault.

Fragesteller

You mean i need to fix css at Quirks Mode? Because i never faced with this problem.. These tables too show badly

You mean i need to fix css at Quirks Mode? Because i never faced with this problem.. These tables too show badly
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 Lösungen 40290 Antworten
Veröffentlicht

This validation report basically tells you what needs to be fixed, but once you set a proper Parse Model and DTD that may change a bit. So those need to be set first before trying to do any real fixing of code.
http://validator.w3.org/check?uri=http://sentel.lt/index2.php

This validation report basically tells you what needs to be fixed, but once you set a proper Parse Model and DTD that may change a bit. So those need to be set first before trying to do any real fixing of code. <br /> http://validator.w3.org/check?uri=http://sentel.lt/index2.php

Fragesteller

But i don't understand, validator says i need to add DOCTYPE, but i added it and error same..

But i don't understand, validator says i need to add DOCTYPE, but i added it and error same..
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 Lösungen 40290 Antworten
Veröffentlicht

Did you upload that change to the server? I am not seeing anything added to the source code that wasn't there an hour ago - as far the doctype goes.

Did you read this? http://validator.w3.org/docs/help.html#faq-doctype


Why not try posting at the Web Development / Standards Evangelism forum at MozillaZine, as this is a bit beyond Firefox user support. The helpers over there are more knowledgeable about web page development issues with Firefox than I am and might be able to refer to better information than I am aware of for this issue.
http://forums.mozillazine.org/viewforum.php?f=25
You'll need to register and login to be able to post in that forum.

Did you upload that change to the server? I am not seeing anything added to the source code that wasn't there an hour ago - as far the doctype goes. Did you read this? http://validator.w3.org/docs/help.html#faq-doctype ------- Why not try posting at the Web Development / Standards Evangelism forum at MozillaZine, as this is a bit beyond Firefox user support. The helpers over there are more knowledgeable about web page development issues with Firefox than I am and might be able to refer to better information than I am aware of for this issue. <br /> http://forums.mozillazine.org/viewforum.php?f=25 <br /> You'll need to register and login to be able to post in that forum.

Fragesteller

Yes i uploaded but validator can't validate. I readed that. That's index begin <meta http-equiv="content-type" content="text/html; charset=utf-8" /> DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

<title>Sentel</title>

Yes i uploaded but validator can't validate. I readed that. That's index begin <meta http-equiv="content-type" content="text/html; charset=utf-8" /> DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd"> <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en"><head> <title>Sentel</title>

Geändert am von mikrafa

cor-el
  • Top 10 Contributor
  • Moderator
17567 Lösungen 158896 Antworten
Veröffentlicht

You can remove the <br> and set the style to .panelebg {word-wrap: break-word;} to make Firefox break the lines automatically.

If you have increased the minimum font size then try the default setting "none" as a high value can cause issues like you described.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)
  • Tools > Options > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"
You can remove the &lt;br&gt; and set the style to .panelebg {word-wrap: break-word;} to make Firefox break the lines automatically. If you have increased the minimum font size then try the default setting "none" as a high value can cause issues like you described. * Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none) *Tools > Options > Content : Fonts & Colors > Advanced > [X] "Allow pages to choose their own fonts, instead of my selections above"