Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Why is it that search box in the centre of the homepage does not work, though it works fine on a secondary user page on the same computer?

  • 5 Antworten
  • 14 haben dieses Problem
  • 142 Aufrufe
  • Letzte Antwort von FrankDodd

more options

Recently updated to latest version of Firefox. On my home page of Mozilla, there is the Firefox "ball" icon and underneath, two long boxes. The first has the word "search" next to it and the second is emty. I can type into the upper box, but when I click search, nothing happens. My wife is a secondary user and has her own logon. Her mozilla homepage is slightly different in that the lower of the two boxes on the homepage conatins "Thank you for choosing Firefox..." and when a question is typed into the search box, clicking on search works fine.

Alle Antworten (5)

more options

You talking about the search container on the default Firefox 4/5 homepage - about:home.

This should fix it.

1. You need to make sure that domStorage is enabled.
Type about:config in the URL bar and hit Enter.
If you see the warning, you can confirm that you want to access that page.
Filter - dom.storage.enabled = the Value should be True
If not, double-click that pref to toggle it to true.

2. Then right-click this pref and select Reset after enabling dom storage
browser.startup.homepage_override.buildID

https://bugzilla.mozilla.org/show_bug.cgi?id=637639#c5
if dom storage is disabled when the profile is upgraded, about:home remains broken even after dom storage is re-enabled

https://bugzilla.mozilla.org/show_bug.cgi?id=637561
about:home does not check for disabled dom storage (null localStorage)

Geändert am von the-edmeister

more options

Thanks. the dom.storage.enabled value was already set to true and so nothing changed. Could it be something to do with AVG which I use?

more options

Try to delete the file <strike>webappsstore.sqlite</strike> chromeappsstore.sqlite in the Firefox Profile Folder

Help > Troubleshooting Information > Profile Directory: Open Containing Folder


(EDITED to correct the file name)

Geändert am von cor-el

more options

I wonder what type of error message appears regarding showSnippets?
{ Ctrl + Shft + J } will open the Error Console.

Did you try resetting this pref - browser.startup.homepage_override.buildID - even though dom storage was already enabled?

The search bar area of the about:home "page" is known as the "searchContainer", while the one below that is the "snippetContainer". It sounds like the snippetContainer is disabled and not receiving data from the Mozilla server and can't display the current message - possibly an indication of corruption that is also affecting the search engine.


Uhm, webappsstore.sqlite or chromeappsstore.sqlite?

Geändert am von the-edmeister

more options

Thanks the-edmeister that put me on the right track. I was having the same problem and in the console was an error: -

Error: gSearchEngine is null Source File: chrome://browser/content/aboutHome.js

This lead me to a thread that discusses this: https://bugzilla.mozilla.org/show_bug.cgi?format=multiple&id=637639

The solution proposed, to go to the about:home page and enter the following into the URL bar, worked for me.

javascript:{localStorage["search-engine"]="{\"name\":\"Google\",\"searchUrl\":\"http://www.google.com/search?q=_searchTerms_&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a\"}";void(0);}

I also had DOM storage enabled during upgrade and indeed all of the time (unless something is messing about with it in the background).

A VERY irritating bug because while you can easily set your home page elsewhere you still feel like there is something broken in the background and actually there is as there is no explanation as to why the problem occurred with DOM stored on.