Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Flash player do not work correctly on IDN URLs

  • 3 Antworten
  • 20 haben dieses Problem
  • 1 Aufruf
  • Letzte Antwort von cor-el

more options

When FF should show a Flash Player element *.swf from a site with IDN URL something goes wrong and halts. (Things go ok in IE and Opera). The problem is related to the IDN URL or FF translation of the URL. An IDN URL in local text may look like this "http://www.stålberg.se/test/index.html" (You may not see this correct if this post is not in UNI code and I do not know if it is, sorry) this is translated into "http://www.xn--stlberg-fxa.se/test/index.html" I can see in the settings for Flash Player, "local storage" that IE is showing the right translated URL, but in FF Flash Player settings for "local storage" shows something at translation with % notation.

When FF should show a Flash Player element *.swf from a site with IDN URL something goes wrong and halts. (Things go ok in IE and Opera). The problem is related to the IDN URL or FF translation of the URL. An IDN URL in local text may look like this "[http://www.stålberg.se/test/index.html]" (You may not see this correct if this post is not in UNI code and I do not know if it is, sorry) this is translated into "http://www.xn--stlberg-fxa.se/test/index.html" I can see in the settings for Flash Player, "local storage" that IE is showing the right translated URL, but in FF Flash Player settings for "local storage" shows something at translation with % notation.

Geändert am von cor-el

Ausgewählte Lösung

It works if I enable punycode by setting the pref network.IDN_show_punycode to true on the about:config page.

Maybe worth filing a bug report about this issue.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (3)

more options

Ausgewählte Lösung

It works if I enable punycode by setting the pref network.IDN_show_punycode to true on the about:config page.

Maybe worth filing a bug report about this issue.

more options

Thanks cor-el that did it, it is working now.

About bug report, I cant find a place to fill out that one. Any hint to that place ?

more options