X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Firefox automatically loads certain websites' mobile phone version.

Veröffentlicht

Gawker sites (io9, lifehacker, gizmodo, etc.) are automatically loaded as mobile versions. Browser cache is cleared, firefox has no extensions or addons. 5 minutes prior to the problem arrising, everything was OK. Nothing was installed, nothing changed. Seems my firefox thinks my laptop is a phone.

URL of affected sites

http://

Gawker sites (io9, lifehacker, gizmodo, etc.) are automatically loaded as mobile versions. Browser cache is cleared, firefox has no extensions or addons. 5 minutes prior to the problem arrising, everything was OK. Nothing was installed, nothing changed. Seems my firefox thinks my laptop is a phone. == URL of affected sites == http://

Mehr Details zum System

Installierte Plugins

  • -EA Battlefield Heroes Updater
  • D'Fusion Web Plugin (2.00.7293.0)
  • Default Plug-in
  • Contribute Firefox IBE Plugin DLL
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape
  • np-mswmp
  • Office Plugin for Netscape Navigator
  • myVR 3D Framework
  • Google Update
  • Unity Player 2.6.1f3
  • Shockwave Flash 10.0 r45
  • GEPlugin
  • 3.0.40818.0
  • Yahoo! activeX Plug-in Bridge
  • Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers

Anwendung

  • User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.9) Gecko/20100315 Firefox/3.5.9 (.NET CLR 3.5.30729)

Weitere Informationen

None!

Fragesteller

I've got the exact same issue in 3.7a5pre with http://www.articsilver.com/

I've got the exact same issue in 3.7a5pre with http://www.articsilver.com/

Fragesteller

I have the same problem with sites like Formula1.com

I have the same problem with sites like Formula1.com

Fragesteller

Same prob here. Gmail and goole maps is loaded as mobile version.

What is mozilla doing about this issue?

Now I have to use IE 8. Thanks!

Firefox sux arse!

Same prob here. Gmail and goole maps is loaded as mobile version. What is mozilla doing about this issue? Now I have to use IE 8. Thanks! Firefox sux arse!

Fragesteller

And still nothing has been done or said about this issue.

Well I'm glad to see mozzila commited.

I guess it's time to move on to greener pastures, fcuk firefox!! I've had enough!

And still nothing has been done or said about this issue. Well I'm glad to see mozzila commited. I guess it's time to move on to greener pastures, fcuk firefox!! I've had enough!

Fragesteller

Anything else ?

Anything else ?

Fragesteller

Problem still exists in 3.7a6pre latest nightly build as of 6/14/2010 10:05 am EDT.

Problem still exists in 3.7a6pre latest nightly build as of 6/14/2010 10:05 am EDT.
cor-el
  • Top 10 Contributor
  • Moderator
17588 Lösungen 159104 Antworten
Veröffentlicht

"Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now" "Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems --- You can also try "Reset all user preferences to Firefox defaults" on the Troubleshoot Firefox issues using Safe Mode start window - See http://kb.mozillazine.org/Resetting_preferences

"Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now" "Remove the Cookies" from sites that cause problems: Tools > Options > Privacy > Cookies: "Show Cookies" Start Firefox in [[Safe Mode]] to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See [[Troubleshooting extensions and themes]] and [[Troubleshooting plugins]] --- You can also try "Reset all user preferences to Firefox defaults" on the [[Safe mode]] start window - See http://kb.mozillazine.org/Resetting_preferences

Hilfreiche Antwort

Have solution : type about:config in url, filter "useragent" and reset the general.useragent.extra.firefox works for me

Have solution : type about:config in url, filter "useragent" and reset the general.useragent.extra.firefox works for me
ccat11 0 Lösungen 14 Antworten
Veröffentlicht

I have tried all of the suggestion and nothing works. Does not happen with Chrome, but I cannot switch due to work. I cannot work with these mobile pages. Seriously losing time and money. Please help. Ff 5.0 on Win7 64bit laptop. Here are current useragent settings (Status default for all):

general.useragent.compatMode.firefox;false

general.useragent.extra.microsoftdotnet

general.useragent.locale;en-US

microsoft.CLR.all_clr_versions_in_useragent;false

I have tried all of the suggestion and nothing works. Does not happen with Chrome, but I cannot switch due to work. I cannot work with these mobile pages. Seriously losing time and money. Please help. Ff 5.0 on Win7 64bit laptop. Here are current useragent settings (Status default for all): general.useragent.compatMode.firefox;false general.useragent.extra.microsoftdotnet general.useragent.locale;en-US microsoft.CLR.all_clr_versions_in_useragent;false

Geändert am von ccat11