Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

ClassicPress password reset links not working when clicking links from mail using Firefox Dev edition

more options

Hi,

I use ClassicPress (fork of WordPress) and I have a problem when requesting a password reset link for it.

When opening the email received to reset password in the firefox dev edition browser and click the reset link I receive an error stating that the link is invalid.

I discovered by trial and error that copying the same link and pasting it manually in a new tab of the same firefox dev edition browser solves the issue because then the link is recognised as valid.

This happened after the update I received last week.

I am a linux mint user if that helps in tracking down the issue.

Hi, I use ClassicPress (fork of WordPress) and I have a problem when requesting a password reset link for it. When opening the email received to reset password in the firefox dev edition browser and click the reset link I receive an error stating that the link is invalid. I discovered by trial and error that copying the same link and pasting it manually in a new tab of the same firefox dev edition browser solves the issue because then the link is recognised as valid. This happened after the update I received last week. I am a linux mint user if that helps in tracking down the issue.
Angefügte Screenshots

Alle Antworten (1)

more options

Hmm, what is the difference between clicking a link and copy/pasting it?

This is a little hard to investigate because links in email messages usually open in a new tab, so the normal Network Monitor loses track of the request and it's tricky to see the exact difference between the clicked link and the pasted link. You could try using the Browser Console (Ctrl+Shift+J). Change to Multiprocess, click the gear/wheel button and turn on Enable Network Monitoring, click the Requests filter to turn it on, then finally click the trash can. Now keep this open while you launch the link from the email and compare with what you expected.

Does it look like some security service or add-on (or beta feature?) is removing the key because it looks like a tracking parameter?

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.