Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Need an older ESR

  • 4 Antworten
  • 0 haben dieses Problem
  • 15 Aufrufe
  • Letzte Antwort von Terry

more options

How do I download 68.10 ESR? Later versions break my files. Don't know why and can not get newer files. All I get is newest version, not the one I need. I can get to the older version directory. But which file do I get?????????

How do I download 68.10 ESR? Later versions break my files. Don't know why and can not get newer files. All I get is newest version, not the one I need. I can get to the older version directory. But which file do I get?????????

Alle Antworten (4)

more options

Should be able to get it from here: https://download.cdn.mozilla.net/pub/firefox/releases/68.10.0esr/

If you're running 64bit Windows and need the English language version, then https://download.cdn.mozilla.net/pub/firefox/releases/68.10.0esr/win64/en-US/ is probably what you need.

They have pretty much every version they ever did there.

Mark H.

more options

Geändert am von Terry

more options

Terry; Oh flooy. Just found the file. It was hidden in plain site:)


That gets me the latest version. I have an install of that but need another install no later that 68.10 ESR, 68.11 ESR breaks the sidebar on my files. I know it is a software problem, but the author is dead:( And beside I have over 500 such files. Upgraded to 68.12 ESR and all went kaplooy:( Went looking and I didn't have a backup of the installer:( So I am using 68.0 ESR, all I had. BTW 10.14.6 and can't upgrade this machine for reasons. But that wouldn't fix this scenario. TCC:}

more options

See the reply by MarkRH.