Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox can't download files from Google Drive.

  • 11 Antworten
  • 0 haben dieses Problem
  • 1 Aufruf
  • Letzte Antwort von jonzn4SUSE

more options

It seems like no matter what I do, I can't get Firefox to download files from Google Drive. It loads for a moment, then it says "The page isn’t redirecting properly". I have confirmed that it's only Firefox because I can download files from Google Drive with Google Chrome. I have disabled Enhanced Tracking Protection, selecting the Standard Enhanced Tracking Protection Setting, and even refreshing Firefox. Though, I noticed that it only works on incognito mode for whatever reason.

It seems like no matter what I do, I can't get Firefox to download files from Google Drive. It loads for a moment, then it says "The page isn’t redirecting properly". I have confirmed that it's only Firefox because I can download files from Google Drive with Google Chrome. I have disabled Enhanced Tracking Protection, selecting the Standard Enhanced Tracking Protection Setting, and even refreshing Firefox. Though, I noticed that it only works on incognito mode for whatever reason.

Alle Antworten (11)

more options

You will have to tweak your security settings. I have the same issue with GD. My security is set to block almost everything, but changing to Strict, I can download from GD. see screenshot

Geändert am von jonzn4SUSE

more options

Setting to strict did not help. In fact, I can't even download GD files now through Incognito mode, with or without strict mode enabled.

more options

Another user posted about this about 6 days ago. The following thread isn't solved, as far as I can tell, but it covers the other typical troubleshooting suggestions:

https://support.mozilla.org/questions/1413370

more options

The issue has now fixed itself. I'm not sure how. This is the weirdest issue I have ever dealt with.

more options

Just watch the status section in the bottom left corner of the browser and it will show you what's stuck. This has been an issue for years with GD. Next time it happens you should try to record the screen.

more options

Firefox now stopped downloading files from GD again. I have recorded it this time as you said. Here

more options

I see the cookie that keeps showing. see screenshot You should just lower your privacy settings when you want to use GD. I've tried allowing the different cookies, but the names keep changing.

more options

You can also try allowing this cookie in the exceptions, but the name will change.

more options

Did you try to disable TPT entirely by daging the slider to the 'off' position ?

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.

more options

I have tried lowering my privacy settings, disabling TPT, and even tried whitelisting the cookie, but it all still doesn't work. I'm stumped.

more options

The only thing I changed is security and GD worked repeatedly without issue. see screenshot Try with Firefox in Safe Mode and then lower your security settings and see what happens. How about trying OneDrive, I rarely have issues with it. It's good to have options.  ;-)) The pop-up save box shows the cookie doc-0s-3g-docs.googleusercontent.com. This is being blocked in my strict settings, but not in standard. I tried in the past to allow these cookies, but google keeps changing the name.

Geändert am von jonzn4SUSE