Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

The width size of search-engine-textbox on Overflow Menu is no full size anymore, Firefox 113

  • 4 Antworten
  • 0 haben dieses Problem
  • 134 Aufrufe
  • Letzte Antwort von cor-el

more options

After update to Firefox 113, the width size of search-engine-textbox on Overflow Menu is no full size anymore.

Before update to Firefox 113 (version 112 or older), the width size is still normal: full size; like search-engine-textbox on Toolbar.

  • 5 screenshot:

[1]: Firefox 113, about version, link image: 1-About-version

[2]: Firefox 113, the width size of search-engine-textbox on Toolbar is full size, link image: 2-Search engine textbox - on toolbar - full width

[3]: Firefox 113, customize mode, the width size of search-engine-textbox on Overflow Menu is now full size, link image: 3-Search engine textbox - on overflow menu - customize mode - full width

[4]: Firefox 113, after customize, the width size of search-engine-textbox on Overflow Menu is no full size anymore. The width is so narrow, link image: 4-Search engine textbox - on overflow menu - after customize - narrow width

[5]: Firefox before 113, screenshot of another post (2022-may-04), the width size of search-engine-textbox on Overflow Menu is now still normal: full size.

link image: image on reddit

link post: post on reddit


Please review and restore the width setting, same as version 112 and earlier.

Thanks and best regards!

P.S.: I posted this on " Mozilla Connect > Discussions" at this link: The width size of search-engine-textbox on Overflow Menu is no full size anymore, Firefox 113

After update to Firefox 113, '''the width size of search-engine-textbox ''on Overflow Menu'' is no full size anymore'''. Before update to Firefox 113 (version 112 or older), the width size is still normal: full size; like search-engine-textbox ''on Toolbar''. ''' * 5 screenshot:''' [1]: Firefox 113, '''about version''', link image: [https://i.postimg.cc/3wcxnhmN/1-About-version.png 1-About-version] [2]: Firefox 113, the width size of search-engine-textbox '''''on Toolbar'' is full size''', link image: [https://i.postimg.cc/DwCvwhC6/2-Search-engine-textbox-on-toolbar-full-width.png 2-Search engine textbox - on toolbar - full width] [3]: Firefox 113, '''customize mode''', the width size of search-engine-textbox '''''on Overflow Menu'' is now full size''', link image: [https://i.postimg.cc/s2vVBLqr/3-Search-engine-textbox-on-overflow-menu-customize-mode-full-width.png 3-Search engine textbox - on overflow menu - customize mode - full width] [4]: Firefox 113, '''after customize''', the width size of search-engine-textbox '''''on Overflow Menu'' is no full size anymore'''. '''''The width is so narrow''''', link image: [https://i.postimg.cc/3wV32BQD/4-Search-engine-textbox-on-overflow-menu-after-customize-narrow-width.png 4-Search engine textbox - on overflow menu - after customize - narrow width] [5]: Firefox before 113, screenshot of another post (2022-may-04), the width size of search-engine-textbox '''''on Overflow Menu'' is now still normal: full size'''. link image: [https://preview.redd.it/easy-way-to-access-the-extensions-in-overflow-menu-using-v0-pxtah81dwfx81.png?auto=webp&v=enabled&s=aaabdcc89952024366b72a31473f72e25d23688a image on reddit] link post: [https://www.reddit.com/r/firefox/comments/ui3x36/easy_way_to_access_the_extensions_in_overflow/?utm_source=share&utm_medium=web3x&utm_name=web3xcss&utm_term=1&utm_content=share_button post on reddit] Please review and restore the width setting, same as version 112 and earlier. Thanks and best regards! P.S.: I posted this on " Mozilla Connect > Discussions" at this link: [https://connect.mozilla.org/t5/discussions/the-width-size-of-search-engine-textbox-on-overflow-menu-is-no/m-p/31324/highlight/true#M11772 The width size of search-engine-textbox on Overflow Menu is no full size anymore, Firefox 113 ]

Ausgewählte Lösung

As a fix for now you can disable this width rule via userChrome.css

#widget-overflow-mainView #search-container { width:unset !important; } /*113*/

EDIT: I've modified the code to make it work only for the overflow area, just to be sure.


It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder with the random name (xxxxxxxx.default-release).

You can find the button to go to the profile folder under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in the profile folder with the random name (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

More info about userChrome.css/userContent.css in case you are not familiar: *https://www.userchrome.org/what-is-userchrome-css.html

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (4)

more options

Hmm. I can replicate this. This looks like a regression of bug 1823791 that sets a default width of 125px to the search bar.

  • 1823791 - Flexible Spaces are taking more space in the toolbar than they used to

 /* Search bar */
 
 #search-container {
   min-width: 125px;
+  width: 125px;
 }
 
 #search-container,
 #wrapper-search-container {
-  flex: 175 175;
+  flex: 175 175 auto;
 }

Geändert am von cor-el

more options

Ausgewählte Lösung

As a fix for now you can disable this width rule via userChrome.css

#widget-overflow-mainView #search-container { width:unset !important; } /*113*/

EDIT: I've modified the code to make it work only for the overflow area, just to be sure.


It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder with the random name (xxxxxxxx.default-release).

You can find the button to go to the profile folder under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in the profile folder with the random name (name is all lowercase). In the chrome folder you need to create a plain text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted. On Mac you can use the TextEdit utility to create the userChrome.css file as a plain text file.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close (Quit/Exit) and restart Firefox when you create or modify the userChrome.css file.

More info about userChrome.css/userContent.css in case you are not familiar: *https://www.userchrome.org/what-is-userchrome-css.html

In Firefox 69 and later you need to set this pref to true on the about:config page to enable userChrome.css and userContent.css in the chrome folder.

Geändert am von cor-el

more options

Thank you, cor-el!

I did as your instructions, and the result was as expected: the width is now normal, full size. ✔

more options

Note that this has been fixed for 115 via bug 1833318.

With this code for userChrome.css to set width:auto in a panel.

#search-container[cui-areatype="panel"] {
  width: auto !important;
}

Geändert am von cor-el