Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How to block extension using policies.json

  • 3 Antworten
  • 0 haben dieses Problem
  • 700 Aufrufe
  • Letzte Antwort von Jonathan

more options

Hi, I planned to block my users from installing extensions/add-ons. I found an article that might be the answer (https://support.mozilla.org/en-US/questions/1308646). I tried to create a simple policy (below), but somehow it does not work (I can still install any add-on/extension). What is wrong with my script? I'm using Firefox ESR 78.11.0 (64-bit) by the way.

My "policies.json" looks like this:

{

"policies": {
  "ExtensionSettings": {
    "*": {
      "blocked_install_message": "Blocked!",
      "install_sources": ["https://addons.mozilla.org/"],
      "installation_mode": "blocked"
    }
  }
}

Sincerely, Jonathan

Hi, I planned to block my users from installing extensions/add-ons. I found an article that might be the answer (https://support.mozilla.org/en-US/questions/1308646). I tried to create a simple policy (below), but somehow it does not work (I can still install any add-on/extension). What is wrong with my script? I'm using Firefox ESR 78.11.0 (64-bit) by the way. My "policies.json" looks like this: { "policies": { "ExtensionSettings": { "*": { "blocked_install_message": "Blocked!", "install_sources": ["https://addons.mozilla.org/"], "installation_mode": "blocked" } } } Sincerely, Jonathan

Ausgewählte Lösung

See:

Note that your curly brackets do not match as you need to add one more '}'. You should see an error on about:policies#errors.

{
 "policies": {
  "ExtensionSettings": {
    "*": {
      "blocked_install_message": "Blocked!",
      "install_sources": ["https://addons.mozilla.org/"],
      "installation_mode": "blocked"
    }
  }.
 }
}

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (3)

more options
more options

Ausgewählte Lösung

See:

Note that your curly brackets do not match as you need to add one more '}'. You should see an error on about:policies#errors.

{
 "policies": {
  "ExtensionSettings": {
    "*": {
      "blocked_install_message": "Blocked!",
      "install_sources": ["https://addons.mozilla.org/"],
      "installation_mode": "blocked"
    }
  }.
 }
}

more options

Cor-El, thank you --- just realized that I missed 1 "}".

Sincerely, Jonathan.