Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox connectivity with many websites broken

  • Keine Antworten
  • 0 haben dieses Problem
  • 3 Aufrufe
more options

I am having problems connecting with nearly all websites at times with Firefox. Often, but not always, getting the browser to reload will complete the connection. Especially problematic are ads that appear from Google search; the links almost never will connect! This is whether I run NordVPN or not.

Using the Chrome browser exhibits none of these problems....but I'm a Firefox guy for many years now.

This all started when I upgraded the motherboard/cpu last year to an ASUS Prime Z590 and i7 cpu. The onboard Intel LAN has latest driver. All other drivers are current.

The other two pc's on my home network have no problems with Firefox at all.

This has been going on too long, and frankly I'm stumped. This happened right out of the box after installing the new mobo, no add ins or themes, just plain jane Firefox.

I'm currently running two add ins, an App to disable WebRTC, and the Dark Reader. Disabling these makes no difference in connectivity problems. Help much appreciated.

I am having problems connecting with nearly all websites at times with Firefox. Often, but not always, getting the browser to reload will complete the connection. Especially problematic are ads that appear from Google search; the links almost never will connect! This is whether I run NordVPN or not. Using the Chrome browser exhibits none of these problems....but I'm a Firefox guy for many years now. This all started when I upgraded the motherboard/cpu last year to an ASUS Prime Z590 and i7 cpu. The onboard Intel LAN has latest driver. All other drivers are current. The other two pc's on my home network have no problems with Firefox at all. This has been going on too long, and frankly I'm stumped. This happened right out of the box after installing the new mobo, no add ins or themes, just plain jane Firefox. I'm currently running two add ins, an App to disable WebRTC, and the Dark Reader. Disabling these makes no difference in connectivity problems. Help much appreciated.

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.