Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Starting firefox hangs without GUI

  • 6 Antworten
  • 0 haben dieses Problem
  • 22 Aufrufe
  • Letzte Antwort von cor-el

more options

Linux Since the last 'automatic' update, Firefox hangs when started, but doesn't show any GUI.

Many experiments later, I can report the following progress:

- I started firefox from the command-line, hoping to see some output (no luck there), and eliminating problems with the window manager launcher (XFCE) - Firefox launches, but in triplicate: 3 instances are running (of firefox, _not_ firefox-bin) - There is no console output. - Running inside gdb shows threads entering and exiting, no errors. On ^C, there's just a message about exiting the current thread. - If I kill two of the instances, the GUI appears, so it seems they are blocking each other - I wanted to trace the startup sequence, so I did `strace ./firefox 2> log` and behold, firefox started! This is why I am reporting this on the actual started firefox. - Which makes me suspect a 'race condition' - surely the strace is slowing things down, allowing one instance to create the GUI. Some code which is not lock-protected?

I'm afraid this could happen again in next session, which is why I report this first, before trying to restart FF.

Linux Since the last 'automatic' update, Firefox hangs when started, but doesn't show any GUI. Many experiments later, I can report the following progress: - I started firefox from the command-line, hoping to see some output (no luck there), and eliminating problems with the window manager launcher (XFCE) - Firefox launches, but in triplicate: 3 instances are running (of firefox, _not_ firefox-bin) - There is no console output. - Running inside gdb shows threads entering and exiting, no errors. On ^C, there's just a message about exiting the current thread. - If I kill two of the instances, the GUI appears, so it seems they are blocking each other - I wanted to trace the startup sequence, so I did `strace ./firefox 2> log` and behold, firefox started! This is why I am reporting this on the actual started firefox. - Which makes me suspect a 'race condition' - surely the strace is slowing things down, allowing one instance to create the GUI. Some code which is not lock-protected? I'm afraid this could happen again in next session, which is why I report this first, before trying to restart FF.

Geändert am von JohnCC

Alle Antworten (6)

more options

I don't have that issue. see screenshot What OS? Does it happen when starting in Safe Mode? Can you try the same steps with another desktop? Let install XFCE and see what happens.

Hilfreich?

more options

Haven't used XFCE in years and it wasn't bad, I'll probably keep it installed. I was not able to replicate the issue. see screenshot

Hilfreich?

more options

jonzn4SUSE, Note that the OS is marked at the top of the page.

When I had the problem, I tried start firefox with:

--safe-mode --Profilemanager

None of this made any difference (i.e. no GUI appeared at any time). As I commented above, after the 'strace' experiment, everything is working just fine.

Hilfreich?

more options

Sorry to report that the issue is back. After re-importing the bookmarks and other items, I restarted firefox (once) with no problems, but the next time, I had the same issue:

No GUI, and in the tasklist I found multiple copies of firefox.

I 'strace'd the startup and effectively found several 'execve's:

execve("/usr/bin/firefox", ["firefox"], 0x7ffe08374500 /* 57 vars */) = 0

Then, at line 280 or so, again:

execve("/usr/lib64/firefox/firefox", ["/usr/lib64/firefox/firefox"], 0x1a97010 /* 56 vars */) = 0

I doubt that this is normal.

I'm sending this from seamonkey...

HELP...

I can send the complete log from strace if needed

Hilfreich?

more options

It seems I cannot append to the original post, so here goes the state of the issue:

- On typing 'firefox' in a terminal, nothing appears on the screen, and ps ax shown 3 (rarely 4) instances of firefox are in memory. ('firefox' processes, not firefox-bin)

- On killing instances processes 2 and 3, the first instances opens and starts normally.

- If I don't kill the instances, and call firefox from another terminal, I get 3 more instances.

- I checked if maybe the XFCE session manager was calling some instances from the start, but no.

So, not much progress...

Hilfreich?

more options

Did you try to start Firefox from a terminal window to see whether errors are reported ?

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.