Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Weitere Informationen

custom search engines automatically adding + to URLS instead of %20

  • 2 Antworten
  • 0 haben dieses Problem
  • 1 Aufruf
  • Letzte Antwort von cor-el

more options

Hi there!

I have a pretty frustrating issue with custom search engines. I use custom search engines all the time to look up words on a dictionary website. In cases where I need to look up something that is more than one word, I'm unable to use this feature because Firefox automatically adds '+' to encode spaces to the URL. since the website that I use does not know how to deal with that, I am unable to use this otherwise convenient feature in cases where my searches utilize spaces.

is this behavior adjustable in any way?

Hi there! I have a pretty frustrating issue with custom search engines. I use custom search engines all the time to look up words on a dictionary website. In cases where I need to look up something that is more than one word, I'm unable to use this feature because Firefox automatically adds '+' to encode spaces to the URL. since the website that I use does not know how to deal with that, I am unable to use this otherwise convenient feature in cases where my searches utilize spaces. is this behavior adjustable in any way?
Angefügte Screenshots

Ausgewählte Lösung

Users also have mentioned this being a problem with using the custom search feature to send text to DeepL for translation. Unfortunately, this is the convention for search sites, and I am not aware of any backdoor way to treat individual search URLs differently.

As a backup, you can create a keyword bookmark. This article has the steps: How to search IMDB, Wikipedia and more from the address bar. At some point, those are going to get imported into search engines, but hopefully not before this problem is resolved in some manner.

When I added the Jisho search box, it included a character set parameter that was somehow corrupted, so I needed to edit the bookmark and this is how it ended up:

So I type j then a space, then my query, and the terms are separated by %20 when Firefox sends the URL.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (2)

more options

Ausgewählte Lösung

Users also have mentioned this being a problem with using the custom search feature to send text to DeepL for translation. Unfortunately, this is the convention for search sites, and I am not aware of any backdoor way to treat individual search URLs differently.

As a backup, you can create a keyword bookmark. This article has the steps: How to search IMDB, Wikipedia and more from the address bar. At some point, those are going to get imported into search engines, but hopefully not before this problem is resolved in some manner.

When I added the Jisho search box, it included a character set parameter that was somehow corrupted, so I needed to edit the bookmark and this is how it ended up:

So I type j then a space, then my query, and the terms are separated by %20 when Firefox sends the URL.

more options

This query URL also works for me: