Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Cannot remove a language

  • 6 Antworten
  • 1 hat dieses Problem
  • 34 Aufrufe
  • Letzte Antwort von cor-el

more options

Hello,

In a previous version of firefox, I could right click within a text area for example, which would allow me to check my spelling. Since upgrading (which was actually from a higher Beta version, to the latest current stable - a new profile was created), I had not had this option. As you can appreciate, it's a very handy tool to have, so I have been attempting to get this function back today.

Within my language section, initially there was only 'English [GB]', which was as it should be. I had 'check spelling as I type' checked also. This did not automatically check as I typed. It did not check at all, not could i right-click to check spelling.

I have since added 'English [US]' to see if this would then allow me to remove and reinstate 'English [GB]', but it did not. I then added a third option which was 'English [CA]'. The config allows me to remove only 'English [CA]', which when pressed removes it from the list, but by pressing the 'set alternatives' button again, you can see that it has returned.

I have since managed to get firefox to check spelling in English [GB] by adding 'British English Dictionary (GB)' (https://addons.mozilla.org/en-GB/firefox/addon/british-english-dictionary-gb/), but now I am also stuck with English US and English CA. EN-US does not allow it to be removed whatsoever, even though it was only there after I manually added it and EN-CA allows me to remove, but returns. No option to apply and restart firefox appears (I've seen this appear in another user youtube video on the subject). Closing and opening makes no difference.

How can I removed English US and English CA please?

6 images attached, in sequence order. Between images 3 and 5 you can see CA being removed and returning (and also no option to remove US). The last image is what I am now trying to get rid of.

Hello, In a previous version of firefox, I could right click within a text area for example, which would allow me to check my spelling. Since upgrading (which was actually from a higher Beta version, to the latest current stable - a new profile was created), I had not had this option. As you can appreciate, it's a very handy tool to have, so I have been attempting to get this function back today. Within my language section, initially there was only 'English [GB]', which was as it should be. I had 'check spelling as I type' checked also. This did not automatically check as I typed. It did not check at all, not could i right-click to check spelling. I have since added 'English [US]' to see if this would then allow me to remove and reinstate 'English [GB]', but it did not. I then added a third option which was 'English [CA]'. The config allows me to remove only 'English [CA]', which when pressed removes it from the list, but by pressing the 'set alternatives' button again, you can see that it has returned. I have since managed to get firefox to check spelling in English [GB] by adding 'British English Dictionary (GB)' (https://addons.mozilla.org/en-GB/firefox/addon/british-english-dictionary-gb/), but now I am also stuck with English US and English CA. EN-US does not allow it to be removed whatsoever, even though it was only there after I manually added it and EN-CA allows me to remove, but returns. No option to apply and restart firefox appears (I've seen this appear in another user youtube video on the subject). Closing and opening makes no difference. How can I removed English US and English CA please? 6 images attached, in sequence order. Between images 3 and 5 you can see CA being removed and returning (and also no option to remove US). The last image is what I am now trying to get rid of.
Angefügte Screenshots

Alle Antworten (6)

more options

I have the same issue. My system is set to English but I am stuck with this "Español" language option which is defaulting to all my input boxes (Including this one) even though I've set English to be first priority.

My keyboard is set to Spanish, which makes me belive this is why Firefox decides this to be my primary language. I need this behavior to stop.

This is driving me mad!

Geändert am von SatsuMX

Hilfreich?

more options

Most of the snapshots relate to the language used in the browser interface rather than the language on web pages which is what spell checking checks. Try removing the dictionaries you don't want to use.

https://support.mozilla.org/en-US/kb/choose-display-languages-multilingual-web-pages

Hilfreich?

more options

Note that the Dictionaries and Language Packs on https://addons.mozilla.org/firefox/language-tools/ are two separate things.

from the link
Installing a dictionary add-on will add a new language option to your spell-checker, which checks your spelling as you type in Firefox. Language packs change your browser’s interface language, including menu options and settings.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker https://support.mozilla.org/en-US/kb/use-firefox-another-language

Hilfreich?

more options

Note that you can't remove the language of your Firefox locale (language of the user interface), so if you have the "en-US" Firefox version then you can't remove this language in "Choose your preferred language for displaying pages", you can add other language and move the default language to a lower position.

Language of the user interface:

"Choose your preferred language for displaying pages":

Hilfreich?

more options

I do not have any dictionary other than English on my Firefox add-ons.

Even if I remove the English dicitionary, I STILL have the "Languages" option in my context menu, with only Spanish available.

I have attached an image, it is quite ridiculous I have no control over this.

Hilfreich?

more options

An installed spell check dictionary would appear on a Dictionaries tab and not under Languages. What you see under Languages are installed language packs that have translations of strings used in the user interface.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.