Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Symbols Don't display correctly in Firefox

  • 3 Antworten
  • 0 haben dieses Problem
  • 12 Aufrufe
  • Letzte Antwort von gevangasteren

more options

I have an odd issue with Firefox that has gone on for some time. Certain symbols don't show up correctly.

I've included an example with Google Calendar showing what I get with Firefox and the correct display using Chrome.

Is this some obscure setting that I need to fix?

I have an odd issue with Firefox that has gone on for some time. Certain symbols don't show up correctly. I've included an example with Google Calendar showing what I get with Firefox and the correct display using Chrome. Is this some obscure setting that I need to fix?
Angefügte Screenshots

Ausgewählte Lösung

Make sure you allow pages to choose their own fonts.

  • Settings -> General -> Language and Appearance -> Fonts -> Advanced
    [X] "Allow pages to choose their own fonts, instead of your selections above"

This can happen if you block remote fonts that are downloaded from internet or otherwise block website fonts. If you use uBlock Origin make sure not to "block remote fonts".

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (3)

more options

Ausgewählte Lösung

Make sure you allow pages to choose their own fonts.

  • Settings -> General -> Language and Appearance -> Fonts -> Advanced
    [X] "Allow pages to choose their own fonts, instead of your selections above"

This can happen if you block remote fonts that are downloaded from internet or otherwise block website fonts. If you use uBlock Origin make sure not to "block remote fonts".

Hilfreich?

more options

Thanks, that was simpler than I thought! :D

Hilfreich?

more options

I have set up Firefox (104.0.1 on macOS 12.5) to "Allow pages to choose their own fonts" and uBlock Origin to NOT "Block remote fonts", but still I see boxes instead of the degree symbols on this page: https://theconversation.com/a-climate-scientist-on-the-planets-simultaneous-disasters-from-pakistans-horror-floods-to-europes-record-drought-189626

If I switch to Reader View, the symbol does display properly.

I’m not sure if this is related, but the Russian Wikipedia has the same problem with Cyrillic text in the font Linux Libertine.

In Safari, both pages display correctly (see attached images of the Conversation article and Russian Wikipedia).

I’d like to know what’s going on here – and what can be done to fix it.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.