Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

High number of processes for Firefox 102.0.1esr with only one tab; How to reduce

  • 2 Antworten
  • 0 haben dieses Problem
  • 4 Aufrufe
  • Letzte Antwort von citizen1138x

more options

Hi,

I am testing v102esr of Firefox for a rollout in September.

One of this issues I have come across is the extremely high number of processes started when opening Firefox.

We have our own website run via Windows Server using IIS. The home page has no remote content - it's all local so I don't believe any remote content is being opened. There is only one tab open.

For each new tab I open I get at least one additional process. So with 10 tabs opened I ended up with 24 processes.

In FF91esr this was 3-5 processes. I also noticed under performance settings I can no longer specify the number of processes.

Is there any way to reduce this number to something more sane, like 3-5?

Also, why is there a Console Window Host running under Firefox?

Is the Node.js also new? I don't recall seeing it before

thanks

Hi, I am testing v102esr of Firefox for a rollout in September. One of this issues I have come across is the extremely high number of processes started when opening Firefox. We have our own website run via Windows Server using IIS. The home page has no remote content - it's all local so I don't believe any remote content is being opened. There is only one tab open. For each new tab I open I get at least one additional process. So with 10 tabs opened I ended up with 24 processes. In FF91esr this was 3-5 processes. I also noticed under performance settings I can no longer specify the number of processes. Is there any way to reduce this number to something more sane, like 3-5? Also, why is there a Console Window Host running under Firefox? Is the Node.js also new? I don't recall seeing it before thanks
Angefügte Screenshots

Ausgewählte Lösung

Those changes to processes are a result of the fission experiment (see link below). You can opt out by changing the following preference to false. fission.autostart You need to restart the browser for the change to take effect.

https://wiki.mozilla.org/Project_Fission

Can you dismiss the "Windows Console Host"? If not, can you provide a screenshot?

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (2)

more options

Ausgewählte Lösung

Those changes to processes are a result of the fission experiment (see link below). You can opt out by changing the following preference to false. fission.autostart You need to restart the browser for the change to take effect.

https://wiki.mozilla.org/Project_Fission

Can you dismiss the "Windows Console Host"? If not, can you provide a screenshot?

Hilfreich?

more options

I can "kill" the console host process, but I shouldn't have to do that.

Anyway, setting the fission.autostart preference to false restores Firefox to a more sane 4 processes.

Sir, you are a legend. Thank you!

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.