On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox suddenly zooms in 400–800% with no user input. Cannot undo.

  • 5 Antworten
  • 1 hat dieses Problem
  • 13 Aufrufe
  • Letzte Antwort von fluckiger

more options

I've been noticing this more and more recently. I'm using Firefox 102.0 on a Mac running Monterey (12.4) with 64GB RAM. Firefox will suddenly zoom up on a screen between 400% up to 800% (I'm guessing; no way to verify this): see screenshot. This happens on random pages without my hitting any keys or clicking on anything, and I cannot replicate it. Note that I do not have screen zoom engaged, nor do I have any sort of zoom mechanism turned on in the OS. Hitting "undo" does nothing, as the browser thinks I'm trying to undo an action on the page, not a zoom. Resetting Firefox or restarting makes no difference.

Note that the screenshot is at actual size, but I have no way to control the resolution at which it shows up for you.

I've been noticing this more and more recently. I'm using Firefox 102.0 on a Mac running Monterey (12.4) with 64GB RAM. Firefox will suddenly zoom up on a screen between 400% up to 800% (I'm guessing; no way to verify this): see screenshot. This happens on random pages without my hitting any keys or clicking on anything, and I cannot replicate it. Note that '''I do not have screen zoom engaged''', nor do I have any sort of zoom mechanism turned on in the OS. Hitting "undo" does nothing, as the browser thinks I'm trying to undo an action on the page, not a zoom. Resetting Firefox or restarting makes no difference. Note that the screenshot is at actual size, but I have no way to control the resolution at which it shows up for you.
Angefügte Screenshots

Alle Antworten (5)

more options

Hi fluckiger, Until you figure out what's causing this zoom issue, can I suggest adding the Zoom Controls from the Customize panel to your toolbar.

Customize Firefox controls, buttons and toolbars https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars

You can quickly restore zoom to 100% (or whatever your global zoom is set to) by clicking on the value in the center.

Hilfreich?

more options

Thank you, RobertJ. I've installed this tool but it appears to have the same function as a regular screen zoom (cmd-+ on the Mac). It'll be loaded, visible and ready the next time the funky zoom specter appears.

Hilfreich?

more options

Have you had any luck?

I came across some older threads regarding Accessibility - Mouse Zoom being inadvertently turned on. Also, Magic Mouse zoom controls. ???

Hilfreich?

more options

It is possible that you accidentally hold/activate the Command key as that makes the scroll wheel work as a zoom control.

You ca try to set mousewheel.with_meta.action = 1 on the about:config page to see if that has effect.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

Action:

0: Nothing happens
1: Scrolling contents
2: Go back or go forward, in your history
3: Zoom in or out (reflowing zoom)
4: Treat vertical wheel as horizontal scroll
5: Zoom in or out (pinch zoom)

Geändert am von Chris Ilias

Hilfreich?

more options

@RobertJ: The Zoom Control that you suggested appears to have resolved the issue in two different instances. I still do not know what's causing it, but so far that's helping. I did have Mouse Zoom turned on in System Preferences (who knew?) but that only zooms in to 200%, and repeating the gesture restores zoom to 100%.

@cor-el: Thank you, but I'm on a Mac using a MagicMouse so there is no scroll-wheel. I think that if this were an issue, I'd also be seeing it in other applications, but Firefox is the only one that's having this problem. Thanks for the suggestion though.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.