Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Weird google chat connection issue

  • 8 Antworten
  • 1 hat dieses Problem
  • 20 Aufrufe
  • Letzte Antwort von cor-el

more options

I am having an odd problem. For years now, I have always used Gmail and its integrated chat function on a daily basis through Firefox. I upgraded to their new chat a while ago with no problems until yesterday.

Starting yesterday, Gmail started getting a bit choppy with me in Firefox on my home connection. Google chat, if it loads at all, will very quickly tell me that it is unable to connect to individual conversations. Indeed, the windows for those conversations will not even load. This is the same regardless of whether I try to load chat through the main Gmail window or if I try to load chat directly at chat.google.com. The site works fine when I test it through Chrome. I have tried clearing cookies and refreshing the site data. It does not seem to matter if I am in incognito mode, so I don't think this is an extension problem. I've added exceptions for my antivirus, so I don't think it's that either.

The REALLY odd thing, however, is that the problem apparently seems to appear only when I am using Firefox and I have my computer connected to my router over ethernet. Firefox loads chat fine when my computer is just on wi-fi (and, again, seems to be fine regardless of whether I'm on ethernet or wi-fi when it comes to Chrome).

I'm not quite sure what to make of this. Other websites seem to be loading in Firefox as normal, regardless of whether I'm on ethernet or wi-fi. Perhaps the only other notable connection problem is that I have had problems with buffering on Spotify that has cropped up at roughly the same time (this one happens on both Chrome and Firefox).

It may well be that my ethernet cable got damaged somehow overnight, but given the fact that other websites have been fine and that I load Gchat fine when using Chrome, I figured I'd ask here to see if there is something I can check on the software side of things because given the setup up in my apartment, restringing a new ethernet cable would be a bit of a hassle. I'm happy to provide any additional information or logs that I can, but I only consider myself an educated layperson when it comes to computers, so I'm not sure what to attach that could be helpful.

Thank you in advance!

I am having an odd problem. For years now, I have always used Gmail and its integrated chat function on a daily basis through Firefox. I upgraded to their new chat a while ago with no problems until yesterday. Starting yesterday, Gmail started getting a bit choppy with me in Firefox on my home connection. Google chat, if it loads at all, will very quickly tell me that it is unable to connect to individual conversations. Indeed, the windows for those conversations will not even load. This is the same regardless of whether I try to load chat through the main Gmail window or if I try to load chat directly at chat.google.com. The site works fine when I test it through Chrome. I have tried clearing cookies and refreshing the site data. It does not seem to matter if I am in incognito mode, so I don't think this is an extension problem. I've added exceptions for my antivirus, so I don't think it's that either. The REALLY odd thing, however, is that the problem apparently seems to appear only when I am using Firefox and I have my computer connected to my router over ethernet. Firefox loads chat fine when my computer is just on wi-fi (and, again, seems to be fine regardless of whether I'm on ethernet or wi-fi when it comes to Chrome). I'm not quite sure what to make of this. Other websites seem to be loading in Firefox as normal, regardless of whether I'm on ethernet or wi-fi. Perhaps the only other notable connection problem is that I have had problems with buffering on Spotify that has cropped up at roughly the same time (this one happens on both Chrome and Firefox). It may well be that my ethernet cable got damaged somehow overnight, but given the fact that other websites have been fine and that I load Gchat fine when using Chrome, I figured I'd ask here to see if there is something I can check on the software side of things because given the setup up in my apartment, restringing a new ethernet cable would be a bit of a hassle. I'm happy to provide any additional information or logs that I can, but I only consider myself an educated layperson when it comes to computers, so I'm not sure what to attach that could be helpful. Thank you in advance!

Alle Antworten (8)

more options

That could be a problem with the TLS 1.3 Early Data feature also known as Zero Round Trip Time Resumption (0rtt). Try changing this preference to false in about:config. You may have to restart afterwards. security.tls.enable_0rtt_data

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Hilfreich?

more options

Thanks, Terry. I tried your idea but the only result seems to be that disabling that preference makes it impossible to sign into google at all. I could load google.com fine, and I could get to the screen where I enter my username, but after that, the screen would process for a bit, and then instead of showing me the screen where I enter my password, I just get a notice that "Sorry, something went wrong there. Try again.". Restoring that flag at least made it possible to log into google again, but the original problem continues in that case. I appreciate the idea, however!

Hilfreich?

more options

I don't know how Google Chat works under the covers, but you might try terminating all of your Google-related service worker processes and see whether forcing the site to reestablish them makes any difference. To get to that feature:

Type or paste about:serviceworkers in the address bar and press Enter to load that internal page.

What you see here may be used primarily for push notifications, i.e., updates from the web service about a new message or connection request. Terminating a service worker when it's just listening shouldn't cause any problems, but you won't get those notifications until the next time you load the site or reload a page from the site, triggering it to reestablish the service worker.

To remove a service worker, click its Unregister button and after a moment it should disappear.

Then try Google Chat again. Any improvement?

Hilfreich?

more options

Hi jscher,

I gave your suggestion a try and also tried 'refreshing' firefox (rather than uninstalling/reinstalling). One (both?) of these did do the trick for one session: the chat loaded right up and everything seemed to be working fine. But I closed the browser and tried logging back on again just now, and the problem reappeared. It again disappears when I get off of my ethernet cable and on to my wi-fi which, frankly, is what I find the most bizarre aspect here. I appreciate the suggestion, though!

Hilfreich?

more options

Does it work normally if you just exit out of Firefox and start it up again, without doing anything else? Just wondering what is needed to reset Firefox's apparent allegiance to a particular network.

Hilfreich?

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Hilfreich?

more options

Jscher: I do occasionally have problems fully logging into google still (that's not entirely unusual, even before the current problems; I had always just assume it was a glitch on Google's side of things), and exiting the browser to try again does generally work in that instance. FWIW: I do have firefox set to clear cookies, site data, and history every time I close the browser.

cor-el: Given that I do have firefox set to clear history/cookies/site data when I close, I *think* this gets to what you were talking about, but let me know if your suggestion would go beyond that. Thank you, though!

Hilfreich?

more options

You can use these steps to make a website recognize and remember you.

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.