Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Incorrect URL Suggestion

  • 4 Antworten
  • 1 hat dieses Problem
  • 12 Aufrufe
  • Letzte Antwort von cor-el

more options

Hello all!

Thanks for your time. When I log in to a certain procurement website associated with my employer, I use the following URL:

https://solutions.sciquest.com/apps/Router/Login?OrgName=MIT.

Once I have done so, subsequent typing in the URL field autocompletes to the shorter host:

https://solutions.sciquest.com/.

The only problem is that when I go to this shorter host, I am "Forbidden \n You don't have permission to access this resource." The website does not seem to allow anyone to go here.


I am on a holy quest to purge this unwanted autocomplete suggestion, but nothing seems to work. It is not appearing because of a bookmark or search history- I can delete places.sqlite to start fresh but the problem resurrects as soon as I first successfully visit the desired URL: https://solutions.sciquest.com/apps/Router/Login?OrgName=MIT.

When I use SQLite to look at places.sqlite, I don't find the shortened URL anywhere in "moz_places" but I do find it in "moz_origins". It appears there with a much greater "frecency" than the lengthier URL for some reason. ID #10 has "solutions.sciquest.com/apps/Router/Login?OrgName=MIT" with frecency 2100, and ID #11 has "solutions.sciquest.com" with frecency 16100.

If I try to delete #11, I'm not able to for reasons likely related to my lack of understanding/proficiency with SQL databases. The DB Browser I am using says "Error deleting record, foreign key constraint failed". But my suspicion would be that even if I did delete it, it would be re-generated whenever I login successfully. What I am able to do is edit the "frecency" field. When I change it to zero, and write the database, the option goes away. I fear that frecency will simply be reset next time I close and reopen however.

Thanks in advance! Dave

Hello all! Thanks for your time. When I log in to a certain procurement website associated with my employer, I use the following URL: https://solutions.sciquest.com/apps/Router/Login?OrgName=MIT. Once I have done so, subsequent typing in the URL field autocompletes to the shorter host: https://solutions.sciquest.com/. The only problem is that when I go to this shorter host, I am "Forbidden \n You don't have permission to access this resource." The website does not seem to allow anyone to go here. I am on a holy quest to purge this unwanted autocomplete suggestion, but nothing seems to work. It is not appearing because of a bookmark or search history- I can delete places.sqlite to start fresh but the problem resurrects as soon as I first successfully visit the desired URL: https://solutions.sciquest.com/apps/Router/Login?OrgName=MIT. When I use SQLite to look at places.sqlite, I don't find the shortened URL anywhere in "moz_places" but I do find it in "moz_origins". It appears there with a much greater "frecency" than the lengthier URL for some reason. ID #10 has "solutions.sciquest.com/apps/Router/Login?OrgName=MIT" with frecency 2100, and ID #11 has "solutions.sciquest.com" with frecency 16100. If I try to delete #11, I'm not able to for reasons likely related to my lack of understanding/proficiency with SQL databases. The DB Browser I am using says "Error deleting record, foreign key constraint failed". But my suspicion would be that even if I did delete it, it would be re-generated whenever I login successfully. What I am able to do is edit the "frecency" field. When I change it to zero, and write the database, the option goes away. I fear that frecency will simply be reset next time I close and reopen however. Thanks in advance! Dave

Alle Antworten (4)

more options

Hmmm... possible workaround. It seems that if I set the frecency of this unwanted suggestion to a large negative number, then continued use slowly increments the number but not enough to overcome the deficit. This all seems rather strange though, I would appreciate a more stable solution.

Hilfreich?

more options

That is up to their site and most likely a security settings so one can't bypass first login to access the site. You need to contact their IT support about this.

Hilfreich?

more options

Firefox seems to autocomplete always to the top level, so you would have to select this longer URL in the drop-down list if you get this choice offered.

You can also consider to use a keyword bookmark to go to the longer URL. Keywords are not only useful for searching (i.e. you use keyword plus search terms), but can also be used for bookmarks you frequently visit.

Hilfreich?

more options

Looks that this will be fixed in Firefox 102.

  • 1597791 - autofill urls, not just origins

(please do not comment in bug reports
https://https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.