Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Yet another request for fixing broken disable Firefox fullscreen animation

  • 1 Antwort
  • 1 hat dieses Problem
  • 9 Aufrufe
  • Letzte Antwort von cor-el

more options

Hi, I browse exclusively full-screen, and I've had a recurring headache making the annoying full-screen animation go away since the inception of Firefox itself- it is the best browser by far and I am loathe to use anything else.

This question comes up time and time again, disabling animations through about:config is very much hit and miss and seems to work completely randomly, sometimes it does, sometimes it don't.

Well, now it don't. Again.

I have the following set:

full-screen-api.transition-duration.enter: 0 0 full-screen-api.transition-duration.leave: 0 0 full-screen-api.transition.timeout: 0 0 full-screen-api.warning.delay: 0 full-screen-api.warning.timeout: 0 dom.animations-api.core.enabled: false

Oddly enough, there used to be options for setting "cosmetic" animations too, but I have no option to change that since FF 100.

Can someone please let me know how to solve this because the annoyance is big enough for me to switch over to Opera or some other browser permanently for how consistently unreliable this function is.

Thank you.

Hi, I browse exclusively full-screen, and I've had a recurring headache making the annoying full-screen animation go away since the inception of Firefox itself- it is the best browser by far and I am loathe to use anything else. This question comes up time and time again, disabling animations through about:config is very much hit and miss and seems to work completely randomly, sometimes it does, sometimes it don't. Well, now it don't. Again. I have the following set: full-screen-api.transition-duration.enter: 0 0 full-screen-api.transition-duration.leave: 0 0 full-screen-api.transition.timeout: 0 0 full-screen-api.warning.delay: 0 full-screen-api.warning.timeout: 0 dom.animations-api.core.enabled: false Oddly enough, there used to be options for setting "cosmetic" animations too, but I have no option to change that since FF 100. Can someone please let me know how to solve this because the annoyance is big enough for me to switch over to Opera or some other browser permanently for how consistently unreliable this function is. Thank you.

Alle Antworten (1)

more options

You can create a new Number pref named ui.prefersReducedMotion on the about:config page to show or block some animations.

  • in Firefox 78+ this includes the location bar breakout
  • in Firefox 80+ this replaces the tab loading indicator with an hourglass
  • set the value to 1 if you want to block animations
    ui.prefersReducedMotion = 1
  • set its value to 0 if you want to see animations
    ui.prefersReducedMotion = 0

You can open the about:config page via the location/address bar. If you get the warning page, you can click the "Accept the Risk and Continue" button.

Geändert am von cor-el

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.