Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Why is my bookmarks library immediately opening the last folder in the library?

more options

I just updated last night to version 98.0 of Firefox, and have noticed that when I click on manage bookmarks that the boomarks now open at the bottom of the various bookmarks folders by default instead of opening at the top like they used to. What happened here? I am including a picture to show where the manage bookmarks section is going by default now instead of where it normally does. Can anyone help fix this?

I just updated last night to version 98.0 of Firefox, and have noticed that when I click on manage bookmarks that the boomarks now open at the bottom of the various bookmarks folders by default instead of opening at the top like they used to. What happened here? I am including a picture to show where the manage bookmarks section is going by default now instead of where it normally does. Can anyone help fix this?
Angefügte Screenshots

Alle Antworten (20)

more options

Yes, that's what happens now. There are arcane ways to change it and they are mentioned in the thread linked below. (Note: remove blank space in link.)

https://forums.mozillazine.org/viewtopic.php?f=38&t=3085733

Geändert am von cor-el

Hilfreich?

more options

Can you just repost that here via copy paste? It'd make it easier than having to go to another site to get the info.

Hilfreich?

more options

There are several relevant posts in the thread. The two methods mentioned are to paste code in the browser console (which may not stick) and autoconfig.js. (Remove space in second link below.)

https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig https://www.userchrome. org/what-is-userchrome-js.html

Hilfreich?

more options

These sound like excellent answers - but for coders. No answer for non-coders, it seems.

Hilfreich?

more options

You can open bookmarks in a sidebar with ctl+b. There is also a way to open the library in a tab but that has problems, apparently.

Hilfreich?

more options

Better than nothing. But not the same as "Manage Bookmarks" in practice, because the left and right columns don't now complement each other in the same way. Manage Bookmarks (as unfortunately now reconfigured) is Ctrl+Shift+O. Why not give users the ability to have it function as it was before with Ctrl+Shift+M ?

Hilfreich?

more options

Perhaps a bug report has been filed. You could look on the site linked below. https://bugzilla.mozilla.org/

Hilfreich?

more options

Thanks. I don't see a bug relating to this, but among so many bookmarks bugs it's hard to tell. It would seem inappropriate, since it was a deliberate change by someone, not a bug. I would like instead to post Ctrl+Shift+M (or similar) as a user suggestion. Where would I post it?

Hilfreich?

more options

The shortcut was changed deliberately; I doubt that the choice of folder was. Other than bugzilla, there is site for posting 'ideas'. https://connect.mozilla.org/

Hilfreich?

more options

I understand that the result of typing Cltrl+Shift+O was changed. But I don't understand what you mean by "the choice of folder" was changed, maybe because I don't know what it was previously. What was it changed from, and what to? Anyway I will post my idea which involves a new shortcut, bringing the same result as Ctrl+Shit+0 had previously, but with a different shortcut.

Hilfreich?

more options

Matthew Montagu-Pollock said

I understand that the result of typing Cltrl+Shift+O was changed. But I don't understand what you mean by "the choice of folder" was changed, maybe because I don't know what it was previously. What was it changed from, and what to? Anyway I will post my idea which involves a new shortcut, bringing the same result as Ctrl+Shit+0 had previously, but with a different shortcut.

I think they mean the fact that if you click on Manage bookmarks, the bookmarks/library window opens at the very bottom of the list of folders you have, instead of at the top where it used to open.

Incidentally, there is something of a workaround; Going to history and then show all history opens the bookmarks/library window at the top as it used to. It's not a perfect solution, but it is a way around it.

Hilfreich?

more options

Not perfect (as you say). But interesting, and new to me!

Hilfreich?

more options

Matthew Montagu-Pollock said

Not perfect (as you say). But interesting, and new to me!

Indeed. The strange thing is that there is no explanation for why the library window popup is coming up now at the very bottom of the folders on the left column, but the show all history shows it at the top, the way manage bookmarks used to, and still should. This change seems arbitary as all hell and makes no sense. I'm hoping this will be fixed to reflect the more natural way the library window used to work prior to version 98.0

Hilfreich?

more options

The change occurred before version 98.0.

Hilfreich?

more options

terry21 said

The change occurred before version 98.0.

Untrue. Prior to this opening manage bookmarks, the library window opened at the very top of the left column. This changed in 98.0

Hilfreich?

more options

Not for me and others. It changed last year or earlier.

Hilfreich?

more options

I too am having this issue of the Bookmarks Library opening at the "Other Bookmarks" folder at the bottom. It used to open at the top.

terry21, Thanks for your fast reply to me from the other thread I innocently started [All Bookmarks Start-Up Folder is now "Other Bookmarks"]

And there is no doubt the issue began with version-98 for me on all of my machines.

I looked over the autoconfig tweaks you pointed to & decided that it is beyond me.

I also looked over the bug list you pointed to decided I could not find what I needed to know. And of course I became overwhelmed searching it and reading a few. So I gave up.

Restarting in 'safe mode' did not help either.

I can only hope that someone comes up with a fix, or maybe the Devs will put it back the way it was.

Still, I do appreciate using Firefox, plus I give big kudos to all that keep it going.

Mike.

Hilfreich?

more options

Marc7 said

terry21 said

The change occurred before version 98.0.
Untrue. Prior to this opening manage bookmarks, the library window opened at the very top of the left column. This changed in 98.0

Is it possible you had done something unusual to customize your Firefox? I've been telling people that the Other Bookmarks folder is selected by default since at least as early as November 20, 2016 (see this thread, for example: https://support.mozilla.org/questions/1147552).

Hilfreich?

more options

Hi jscher2000,

I'm not sure who you are asking, but speaking for myself, I use about half-a-dozen extensions (plugins?) and those came from the Mozilla/Firefox 'repository'.

For me, the change occurred with the v98 update. I use my bookmarks many times a day.

As far as your note about it changing in '16, I don't know what to say...

I wish only that I could have it back to normal.

I mean, who opens a book in the front all their life, and then suddenly it must be opened at the back from then on?

It's crazy.

Regards,

Mike.

Hilfreich?

more options

Hi Mike, this isn't something an add-on could change, those aren't active in the Library window.

Showing the Other Bookmarks folder is hard-coded into the Manage Bookmarks/Show All Bookmarks menu command:

<command id="Browser:ShowAllBookmarks" oncommand="PlacesCommandHook.showPlacesOrganizer('UnfiledBookmarks');"/>

Overriding that would have required something obscure like a so-called "userChrome.js" startup script.

Perhaps what was happening was a glitch in your Places database (for the three of you) that caused Firefox to be unable to switch from All Bookmarks to Other Bookmarks, and somehow Firefox 98 fixed the problem. Otherwise, it's hard to imagine how you didn't get this change a long time ago like the rest of us.

Hilfreich?

  1. 1
  2. 2
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.