Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

yahoo keeps answering foxfire searches

more options

When I run a search in Foxfire the result pulls up in Yahoo. How do I make this stop. I want to have foxfire pull results. Foxfire is set as my default.

When I run a search in Foxfire the result pulls up in Yahoo. How do I make this stop. I want to have foxfire pull results. Foxfire is set as my default.

Ausgewählte Lösung

In the U.S., Firefox's default search engine is Google. In fact, Firefox doesn't even come with a Yahoo! search option built in. So... what is causing that.

I suggest first trying to reselect your default settings for your search site and home page:

Are you able to change those, and does the change stick?


Otherwise, search hijacking can be caused by either an add-on or by external malware. Let's start with checking for problem extensions on your Firefox:

Open the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage.

You shared your list and the one that looks potentially sketchy to me is Manuals Library Search -- can you disable that one? Of course, anything that mentions Yahoo! or search you also could disable. Sometimes they mention privacy. If there are any you just do not remember installing or why, go ahead and disable (or remove) those as well. For your privacy and security, don't let mystery programs linger here.

If your Add-ons page is blank or is blocked, you can restart Firefox in its Safe Mode to do the above review:

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to bypass issues that can cause problems with pages.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Can you regain control of your searches?

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (4)

more options

Ausgewählte Lösung

In the U.S., Firefox's default search engine is Google. In fact, Firefox doesn't even come with a Yahoo! search option built in. So... what is causing that.

I suggest first trying to reselect your default settings for your search site and home page:

Are you able to change those, and does the change stick?


Otherwise, search hijacking can be caused by either an add-on or by external malware. Let's start with checking for problem extensions on your Firefox:

Open the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage.

You shared your list and the one that looks potentially sketchy to me is Manuals Library Search -- can you disable that one? Of course, anything that mentions Yahoo! or search you also could disable. Sometimes they mention privacy. If there are any you just do not remember installing or why, go ahead and disable (or remove) those as well. For your privacy and security, don't let mystery programs linger here.

If your Add-ons page is blank or is blocked, you can restart Firefox in its Safe Mode to do the above review:

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to bypass issues that can cause problems with pages.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Can you regain control of your searches?

Hilfreich?

more options

Thank you for the help found the issue an add-on called Manuals Library requests to change the browser to Yahoo. I turned off the yahoo browser. The Manuals Library was the only extension above the Recommended extensions, I don't know what it is does it have to be there? It is late here I will not respond until tomorrow.

Hilfreich?

more options

Firefox itself is a web browser as Yahoo in this case is a search engine.

The "Find Manuals Now & Custom Web Search" extension does not come in any version of Firefox so you may have installed it at some point and forgot. If you have no need for it then you may as well uninstall it. https://addons.mozilla.org/firefox/addon/findmanualsnowcustomwebsearch/

Firefox has not come with Yahoo search as one of the search defaults for over four years now. https://blog.mozilla.org/en/mozilla/mozilla-files-cross-complaint-against-yahoo-holdings-and-oath/

Hilfreich?

more options

risley215 said

Thank you for the help found the issue an add-on called Manuals Library requests to change the browser to Yahoo. I turned off the yahoo browser. The Manuals Library was the only extension above the Recommended extensions, I don't know what it is does it have to be there? It is late here I will not respond until tomorrow.

If you don't know why it's there, get rid of it.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.