Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How Do I Disable All Shortcut Keys

  • 3 Antworten
  • 1 hat dieses Problem
  • 421 Aufrufe
  • Letzte Antwort von Bob's Firefox

more options

I have read the same named question that has been archived and have not found a solution to my problem there. I'm using Macro Express to define my own keystrokes which works fine outside of FF. One of the keystrokes I have defined is Ctrl-Shift-k. A suggestion was to disable Developer Tools via about:config -> devtools.enable = false, but when I tried to use my definition of Ctrl-Shift-k, instead FF told me "You activated a Developer Tools shortcut. If that was a mistake, you can close this Tab." when in fact I wanted to have it invoke my own definition.

How can I override this (and other) keystrokes when using FF?

Ausgewählte Lösung

You can disable the developer tools entirely via devtools.policy.disabled = false on the about:config page.

Diese Antwort im Kontext lesen 👍 2

Alle Antworten (3)

more options

Hi Bob, it's complicated.

Firefox doesn't have any built-in feature to reassign its own keyboard shortcuts. However, many of them can be intercepted by pages and repurposed. There are at least two general purpose add-ons that leverage this behavior by injecting your desired changes into pages:

Depending on what you want Ctrl+Shift+K to do, that might be a workaround for you.

BUT!! That said, a program like Macro Express should be intercepting key combinations before they ever reach Firefox, shouldn't it -- it works at the system level? Maybe it is not working as expected. Do the other keyboard shortcuts you set up in Macro Express work while Firefox is the active window or do they trigger Firefox actions?

Hilfreich?

more options

Ausgewählte Lösung

You can disable the developer tools entirely via devtools.policy.disabled = false on the about:config page.

Hilfreich?

more options

cor-el: thanks for the suggestion. That solved the problem.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.