Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Manage Exceptions button for cookies exceptions is not working

  • 2 Antworten
  • 1 hat dieses Problem
  • 29 Aufrufe
  • Letzte Antwort von piscium

more options

Manage Exceptions button for cookies is not working for me since FF88 or 89, don’t remember which version precisely. I click on the button and the dialogue box that would normally appear to set exceptions does not pop up. Moreover it looks like when I click on the button the user interface on that tab freezes for a period. My FF profile is customised. I know if I start with a blank profile the issue goes away. I have another that works fine. However I would rather try to fix this issue in my current profile. I poked around in about:config but so far have had no success.

Any ideas? I searched google but could not find anything. Also checked mozilla bugzilla a while back without success. I am using FF 92 on Arch Linux.

Ausgewählte Lösung

Thanks for your help, I solved the issue. Although you did not tell me the solution, you guided my stream of thoughts towards it. After trying various things without success I decided to use the program below on permissions.sqlite: https://sqlitebrowser.org/

In less than a minute I found something odd: the permissions for the Yahoo cookies (http and https) were 9. I changed that to 1, saved and closed the database, started Firefox and the problem disappeared.

I have no idea how the database got corrupted. That setting exists for several years, and the corruption happened a few months ago after a major FF upgrade. I don't know if the corruption was a result of the upgrade, it could have been just a coincidence. Anyway, all good now.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (3)

more options

Do exceptions work like set via "Tools -> Page Info -> Permissions" as you should be able to set an exception for the domain in the current tab ?

Try to rename/remove permissions.sqlite in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).


Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Hilfreich?

more options

Thanks for your help, I solved the issue. Although you did not tell me the solution, you guided my stream of thoughts towards it. After trying various things without success I decided to use the program below on permissions.sqlite: sqlitebrowser

In less than a minute I found something odd: the permissions for the Yahoo cookies (http and https) were 9. I changed that to 1, saved and closed the database, started Firefox and the problem disappeared.

I have no idea how the database got corrupted. That setting exists for several years, and the corruption happened a few months ago after a major FF upgrade. I don't know if the corruption was a result of the upgrade, it could have been just a coincidence. Anyway, all good now.

Geändert am von piscium

Hilfreich?

more options

Ausgewählte Lösung

Thanks for your help, I solved the issue. Although you did not tell me the solution, you guided my stream of thoughts towards it. After trying various things without success I decided to use the program below on permissions.sqlite: https://sqlitebrowser.org/

In less than a minute I found something odd: the permissions for the Yahoo cookies (http and https) were 9. I changed that to 1, saved and closed the database, started Firefox and the problem disappeared.

I have no idea how the database got corrupted. That setting exists for several years, and the corruption happened a few months ago after a major FF upgrade. I don't know if the corruption was a result of the upgrade, it could have been just a coincidence. Anyway, all good now.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.