Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox "Clear Data..." selection box not working.

more options

I'm running Firefox 91.0.2 on a UK Windows 10 PC. I'm simply trying to clear my browser cache, but not my cookies. My problem:

(1) Click on the "triple bar" icon, top-right, to open Firefox menu. (2) Click "Settings". (3) Click "Privacy & Security" on left side. (4) Scroll down (if necessary) to "Cookies and Site Data" section. (5) Click on "Clear Data..." button. (6) Two options are displayed: "Cookies and Site Data" and "Cached Web Content". I do NOT want to clear all my cookies as relogging into all my websites would be a pain. I ONLY want to clear my cache. (7) I attempt to click on the buttons to select the option I want, but the buttons appear to be UNRESPONSIVE. There are no ticks/check marks appearing. The only difference is that the border of the buttons changes colour slightly, but it's VERY hard to see. (Maybe this is connected with using the dark theme?) No matter what combination of button clicks I use, the two buttons remain unchecked, and they look identical. (8) If I click the "Clear" button a warning appears saying that all my cookies will be deleted. This is NOT what I want. (9) I give up and click the "Cancel" button. (10) I close down Firefox, return to the Windows desktop, and close down all possible applications and processes. I try to repeat the above steps, but the same problem happens again. (11) I give up and try to create a Firefox bug report, but I find there is now no bug reporting facility! Users can no longer submit bugs for Firefox!!! So I come here and post my problem, hoping that the community can help. (12) Thanks for any help offered!

Ausgewählte Lösung

Hi Keith, is it this glitch caused by setting browser.proton.enabled to false:

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (5)

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

and whatever else you want.

Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

more options

FredMcD, thank you for your quick reply.

Firstly, running Firefox in "Troubleshooting" mode does not solve the problem with the "Clear Data..." selection buttons. The buttons remain unresponsive and uncheckable. As an experiment, I have also looked at other checkboxes in the settings menu, and it appears all of them are misbehaving in the same way.

Secondly, I am only trying to clear my cache as a one-off troubleshooting step for another malfunctioning application. If I follow your recommended change to my settings, I believe that my cache will be cleared every time I shut down Firefox. This means that in subsequent browsing sessions, I will have to wait for all websites to reload their graphic images and other data. I think this would negatively impact my browsing experience, and so I don't think I would want to use it as a permanent solution, although it may help me with my immediate problem.

Thank you for your time and effort.

Geändert am von keith.c.ballard

more options

keith.c.ballard said

I am only trying to clear my cache as a one-off troubleshooting step for another malfunctioning application.

Please explain the problem in detail. What happens? What is/are the exact error message(s) ?


Location of the cache/cache2 folder; Windows: *C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>\ Mac: ~/Library/Caches/Firefox/Profiles/ Linux: ~/.cache/mozilla/firefox/

Close Firefox. Open your file browser to the above and remove the folder.

more options

Ausgewählte Lösung

Hi Keith, is it this glitch caused by setting browser.proton.enabled to false:

more options

Eureka! jscher2000 you appear to have found (and fixed) my problem. Let me set out the events of the past few weeks to explain. Apologies if this is a bit long, but it's quite a complex story so I want to set it out clearly in case anyone has any further advice, or in case anyone else can benefit from my experiences.

(1) Some time ago (several weeks? - I don't remember exactly), Mozilla updated Firefox and made some changes to its appearance. Many users were in uproar because the size and/or padding of many of the Firefox screen elements was increased, and there were lots of complaints about wasted screen space, and reduced space for viewing web pages. I was affected because of the changes to the padding in the drop-down menus. My bookmarks menu expanded so much that it looked ugly, unwieldy, and I had to use my mouse wheel to scroll the menu up and down to see all of my bookmark folders.

(2) Like many Firefox users, I started to monitor Mozilla's posts, and those of the community, to see if anyone was going to correct things. This was the first time I heard of a new "style" for Firefox, known as "Proton".

(3) After a couple of days, some of the more techie Firefox users started publishing information about going into the "about:config" settings, and turning off some of the changes that Mozilla had made, so that we could get back to a decent-looking browser. I found a post which had a number of favourable replies, and decided to test out the suggested changes. The new settings were:

browser.proton.contextmenus.enabled = false browser.proton.enabled = false browser.uidensity = 1

After making these changes, I found that the drop-down menus went back to normal, and I was a happy user again.

(4) However, Mozilla then decided to push out one or more further updates, and I found that, despite still having the about:config changes in place, the browser was now ignoring these settings, and I was back to having an oversized bookmarks menu again!

(5) At this point, I was so angry that I was contemplating dumping Mozilla entirely and switching to a new browser. After being a Firefox user for about twenty years, it would have been a massive wrench and a great inconvenience, but I wasn't prepared to be forced into accepting bad changes by a company which appears to have lost all respect for its users.

(6) However, I happened to find another post from a techie Firefox user suggesting another strategy for regaining control over the browser. This involves setting up a user settings file, "userChrome.css", and forcing the browser to read it on startup. I implemented the suggested changes, creating a file which contains the following (KB are my initials so I can differentiate this from other files):

/* Replace this SAMPLE CONTENT with your own CSS */ /* KB Custom CSS file */

/*** Tighten up drop-down/context/popup menu spacing ***/

menupopup > menuitem, menupopup > menu {

 padding-block: 4px !important;

}

root {
 --arrowpanel-menuitem-padding: 4px 8px !important;

}

Once again, this fixed my problem! However, I made a slight mistake at this point, because I didn't go back and revert the first set of about:config changes.

(7) For the last couple of weeks, everything with Firefox has been working fine, and I hadn't noticed any further problems.

(8) Over the last couple of days I have been "forced" or "browbeaten" to install the new version of "Google Drive". Although it generally seems to work, I'm getting a lot of error messages (apparently spurious), and the status displays appear to be showing nonsense. In my attempts to troubleshoot this piece of rubb... er, software, it was recommended as a first step that I clear my browser cache. And that's when my current problem, detailed in my first post, started to happen.

(9) Now jscher2000, you have spotted the cause of the problem. I have just gone back into about:config, and I've changed "browser.proton.enabled" back to "true". On restarting Firefox, all of the check boxes in the Firefox settings menu are working correctly with ticks showing where they should, and I still have my normal-sized bookmarks menu.

(10) I have just been back to the "Clear Data..." menu and succesfully cleared my cache, and everything seems to be working well. I hope this is the end of my problem! (At least, the end of my Firefox problem. It remains to be seen if I can get Google Drive working as it should! Please cross your fingers for me!)

Thanks to you jscher2000 and also FredMcD for your time and expertise!

Geändert am von keith.c.ballard