Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

After updating to 91 version all my addons stopped working in private mode. How to enable all addons to work in private mode at once ?

  • 6 Antworten
  • 1 hat dieses Problem
  • 21 Aufrufe
  • Letzte Antwort von cor-el

more options

After updating to 91 version almost all my addons stopped working in private mode.

When FF team decided to block all addons for private mode there was a setting in about:config to allow all adons to work in private mode, but it looks like it is removed in 91 (?) or renamed (?).

So, how to enable all addons to work in private mode at once ? I have a lot and clicking each one in its settings will take a lot of time.

Ausgewählte Lösung

I wrote a script to solve my problem - github repo. It updates extensions prefs in user's profile dir to allow extensions in private mode.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (6)

more options

Hey there!

I've found this link to a case similar to yours: https://support.mozilla.org/en-US/questions/1212268

Hope it helps!

Bithiah

Hilfreich?

more options

A little bit digging gave me that the setting "extensions.allowPrivateBrowsingByDefault" is indeed removed. This is sad, so for now there is no easy way to enable all addons in private windows at once.

Hilfreich?

more options

Hi Tim,

  • Click the menu button Fx89menuButton, click Add-ons and Themes and select Extensions.
  • Click on the extension that you would like to manage.
  • This will open a panel where you can manage extension settings.
  • Next to Run in Private Windows, select Allow to enable the extension to work in private browsing,
  • or select Don’t Allow to disable it in private browsing. Once you have made your selection, you can exit the Add-ons Manager.

See More: https://support.mozilla.org/en-US/kb/extensions-private-browsing

Hilfreich?

more options

Note that there used to be a pref to allow extensions automatically in PB mode (extensions.allowPrivateBrowsingByDefault), but support for this pref has been removed in Firefox 91 as it was causing issues with extensions that weren't allowed to run in PB mode via their manifest.

Hilfreich?

more options

Ausgewählte Lösung

I wrote a script to solve my problem - github repo. It updates extensions prefs in user's profile dir to allow extensions in private mode.

Hilfreich?

more options

See also:

  • 1627939 - Problem with extensions with incognito: not_allowed in their manifest and flag allowPrivateBrowsingByDefault

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.