Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

after v91 update, background and styling don't render properly

  • 2 Antworten
  • 1 hat dieses Problem
  • 14 Aufrufe
  • Letzte Antwort von matt136

more options

After the v91 update, all websites look different. Stylesheets are loading, but background images do not. Buttons are not styled. Text is always black. Links are always blue. It's like the website's own CSS is selectively ignored in favor of some sort of bland default.

None of the following have fixed the issue: 1- View Menu > Page Style is set to Basic Page Style. I've flipped this to No Style and back. CSS is rendering, just not correctly.

2- I restarted FF in safe mode (option-click to launch).

3- I trashed the prefs.js file.

4- The problem still exists in Troubleshooting mode.

5- I cleared the cache.

6- I switched to the Dark theme.

7- I removed all extensions and add-ons (other than whatever comes with the browser).

8- I reinstalled v91 from a fresh download.

This problem breaks FF internals; e.g. see the screenshot of the About:config page, where a popup is transparent because (presumably) its background isn't rendering.

After the v91 update, all websites look different. Stylesheets are loading, but background images do not. Buttons are not styled. Text is always black. Links are always blue. It's like the website's own CSS is selectively ignored in favor of some sort of bland default. None of the following have fixed the issue: 1- View Menu > Page Style is set to Basic Page Style. I've flipped this to No Style and back. CSS is rendering, just not correctly. 2- I restarted FF in safe mode (option-click to launch). 3- I trashed the prefs.js file. 4- The problem still exists in Troubleshooting mode. 5- I cleared the cache. 6- I switched to the Dark theme. 7- I removed all extensions and add-ons (other than whatever comes with the browser). 8- I reinstalled v91 from a fresh download. This problem breaks FF internals; e.g. see the screenshot of the About:config page, where a popup is transparent because (presumably) its background isn't rendering.
Angefügte Screenshots

Ausgewählte Lösung

Hi Matt, it looks like you are running Firefox on MacOS.

As mentioned in the release notes, "Firefox [91] now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS."

Is it possible you have that setting?

If so, please try one or both of these two options:

(1) Turn off the system-level setting. This appears to be the most effective workaround.

(2) Disable High Contrast mode in Firefox. See: Disable high contrast mode in Firefox.

For both changes, you might need to Quit Firefox and start it up again to see the normal display.

Any difference?

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (2)

more options

Ausgewählte Lösung

Hi Matt, it looks like you are running Firefox on MacOS.

As mentioned in the release notes, "Firefox [91] now automatically enables High Contrast Mode when "Increase Contrast" is checked on MacOS."

Is it possible you have that setting?

If so, please try one or both of these two options:

(1) Turn off the system-level setting. This appears to be the most effective workaround.

(2) Disable High Contrast mode in Firefox. See: Disable high contrast mode in Firefox.

For both changes, you might need to Quit Firefox and start it up again to see the normal display.

Any difference?

more options

Jefferson, thank you! Disabling the system setting indeed fixes the problem.