Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How to turn off addrress bar searches?

  • 4 Antworten
  • 1 hat dieses Problem
  • 34 Aufrufe
  • Letzte Antwort von tgrace_007

more options

Hi All,

I have searched the web and found this 'https://support.mozilla.org/en-US/questions/1284577'. I followed the steps but it didn't disable this crap. I HATE this and I want to turn it off. How? I use the search bar not the address bar for my searches.


Thanks for any help,

Charles

Ausgewählte Lösung

In what cases does Firefox initiate a search when you type the location bar ?

Note that some ISPs redirect you to a generic search page if a DNS lookup fails instead of sending a 404 page not found notice. This will make it impossible for Firefox to react properly since you always get a valid page.

You can disable searching via the location bar by setting keyword.enabled = false on the about:config page. There are also settings in "Settings (Options/Preferences) -> Search" that apply to the location bar.

For Firefox 90 and the Firefox Home page you can also look at:

  • browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar = false
Diese Antwort im Kontext lesen 👍 1

Alle Antworten (4)

more options

Ausgewählte Lösung

In what cases does Firefox initiate a search when you type the location bar ?

Note that some ISPs redirect you to a generic search page if a DNS lookup fails instead of sending a 404 page not found notice. This will make it impossible for Firefox to react properly since you always get a valid page.

You can disable searching via the location bar by setting keyword.enabled = false on the about:config page. There are also settings in "Settings (Options/Preferences) -> Search" that apply to the location bar.

For Firefox 90 and the Firefox Home page you can also look at:

  • browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar = false

Hilfreich?

more options

Hi,

I use FF v90.0.2 and all my searches now go thru the address bar. I load FF and I have the default FF screen showing. It has a search bar on it. As soon as I type 1 character in the search bar FF automatically switches the search to the address bar. This is what I HATE. I type in the search bar and FF switches the search to the address bar, because I can see it as it does, all the following text I type appears in the address bar and the address bar drop down shows up.

How the make FF do searches thru the search bar only?

Seems, browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar was the setting. Once I turned it to false FF now works as I want. Thank you for the help.


Thanks for the help,

Charles

Geändert am von CharlesEF

Hilfreich?

more options

I hate the address bar search. Found multiple "solutions" but Charles' was the only one that actually worked. Why did Mozilla initiate this annoying "feature"?

Thanks Charles.


Joey

Hilfreich?

more options

FINALLY!!!! I had been going nuts with all the previous directives to try to kill the aggravating "Search from Address Bar" feature.

A big, BIG thanks to cor-el for the solution!!

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.