Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

No effect after importing root CA certificate

  • Keine Antworten
  • 1 hat dieses Problem
  • 1 Aufruf
more options

I'm running Ubuntu 18.04 LTS and Firefox 89.0.1.

My company runs some internal servers with a self signed root CA, hence I want to add it to Firefox's certificate store in order to trust in one go all the SSL certificates this CA issued.

Problem is, whatever I try, my Firefox is playing dumb.

I've enabled security.enterprise_roots.enabled (which to my knowledge should let Firefox trust OS keystore certificates, something that isn't supported on Linux tho, correct me if I'm wrong). Then I've tried the UI import process: I provide the certificate file, check the box to tell Firefox to trust it for identifying web sites, and confirm the import. Nothing happens, it's just not added to the CA list.

Same result when manually copying certificate files to ~/.mozilla/certificates (cert files here have read access for user/group/others).

I'm out of options. I've even done again all of the above on a brand new profile.

Is there a way to "debug" this importing process, to figure out what Firefox is not liking?