Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Turning Off Update Reminders in Firefox

  • 9 Antworten
  • 1 hat dieses Problem
  • 27 Aufrufe
  • Letzte Antwort von fake.pgibbons

more options

Hello,

How can I permanently deactivate this nagging update reminder in the upper right corner (green arrow over Application Menu button) and frequent pop-ups in upper right corner where I have to repeatedly click on "Not Now"?

I'm not upgrading to v89 because the next update will once again BREAK my userChrome.css code and my user interface (with tabs on bottom and custom button images) will appear scrambled.

I'm quite tired of having to jump through hoops and search for CSS solutions to fix these issues every few updates. It causes me too much anxiety.

I'm sticking with v88.0.1 for the forseeable future.

How can I shut off this annoying update reminder permanently?

Thanks.

Angefügte Screenshots

Geändert am von Slouch

Ausgewählte Lösung

Many thanks, FredMcD.

I don't mind doing registry tweaks, and that worked fine for me.

Big sigh of relief!

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (9)

more options

How do you completely turn off update checks in Firefox v64? You can use a policies.json file to disable updates for all users. https://github.com/mozilla/policy-templates/blob/master/README.md or https://winaero.com/blog/disable-updates-firefox-63-above/

You can use a policies.json file in the distribution folder in the Firefox installation folder instead as also listed in the article, so no need to use GPO keys in the Windows Registry. • https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson

Hilfreich?

more options

Ausgewählte Lösung

Many thanks, FredMcD.

I don't mind doing registry tweaks, and that worked fine for me.

Big sigh of relief!

Hilfreich?

more options

Unfortunately, this didn't work for me.

C:\Program Files\Mozilla Firefox\distribution\policies.json

Contents;

{

 "policies": {
   "AppAutoUpdate": false
 }

}

Hilfreich?

more options

Note that if you use this policy that you won't be able to update Firefox and it is important to get the latest security updates. You would have to install the full version or disable the policy.


Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#PanelUI-menu-button .toolbarbutton-badge-stack {
 display:none !important;
}

Hilfreich?

more options

cor-el said

Add code to the userChrome.css file below the default @namespace line. </blockquote>

Unfortunately that didn't work either. My full file so far; (No idea what that PanelUI button is that you're trying to hide)

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

  1. PanelUI-menu-button .toolbarbutton-badge-stack {
display:none !important;

} {

 "policies": {
   "AppAutoUpdate": false
 }

}

Hilfreich?

more options

The code for userChrome.css in the chrome folder in the Firefox profile folder is about hiding badges on the "3-bar" Firefox menu button like to notify you like when there is a Firefox update is available.

Policies need to be in policies.json in the distribution folder in the Firefox program folder and not in userChrome.css.

{
 "policies": {
   "AppAutoUpdate": false
 }
}

Hilfreich?

more options

Oh you were telling me to edit a different file. Why do I need to edit the userChrome file to make policies work? That doesn't make any sense. What button are you trying to get me to hide?

Hilfreich?

more options

The userChrome.css file only needs this content and this code hides a badges that Firefox sometimes attaches to the "3-bar" Firefox menu button as a way to notify you.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#PanelUI-menu-button .toolbarbutton-badge-stack {
 display:none !important;
}

If you want to block updating entirely then you can use a policies.json file. The two files have different purposes and are in different locations (userChrome.css in the chrome folder in the profile folder and policies.json in the distribution folder in the Firefox program folder), so do not get confused.

Hilfreich?

more options

Hi, I am extremely annoyed by the update popup, so annoyed in fact that I created this account just to write this. Look at google chrome for example, the update button just turns red but there is never a popup about it and I often take a few weeks before I do the update (when I restart). However in firefox, all the freaking time these popups about updates, it is sooooo annoying and of course no option to turn that off. Either you guys get this fixed (I give you a few weeks to get it done), or I will uninstall firefox for good, the choice is yours.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.