Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox 89 on Linux : use not existing Helvetica font broke lot of website

  • 4 Antworten
  • 1 hat dieses Problem
  • 137 Aufrufe
  • Letzte Antwort von Shnoulle

more options

I have Firefox ESR on debian Linux , I didn't have Helvetica font on my font: i didn't need it.

With Firefox ESR : the font used for github menu or for twitte are "Liberation Sans" But on 89 version , on same computer with same font preferences : it's the unexisting Helvetica : then website are really awful.

How can than happen ? How can i fix this , I really don't need Helvetica, why is this font set ?

I put some screenshot showing the issue and the preferences set.

Thanks you

I have Firefox ESR on debian Linux , I didn't have Helvetica font on my font: i didn't need it. With Firefox ESR : the font used for github menu or for twitte are "Liberation Sans" But on 89 version , on same computer with same font preferences : it's the unexisting Helvetica : then website are really awful. How can than happen ? How can i fix this , I really don't need Helvetica, why is this font set ? I put some screenshot showing the issue and the preferences set. Thanks you
Angefügte Screenshots

Ausgewählte Lösung

OK : issue already reported : regression with Firefox 89 : https://bugzilla.mozilla.org/show_bug.cgi?id=1714318

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (4)

more options

This could vary by OS but when I check the font-family used by the page, I get:

body { font-family: -apple-system,BlinkMacSystemFont,Segoe UI,Helvetica,Arial,sans-serif,Apple Color Emoji,Segoe UI Emoji; }

On my Windows, the font actually used is Segoe UI.

Are you sure you don't have Helvetica installed?

There is a preference intended to limit fonts used by pages if you don't want "user installed" fonts to be used. You could try this and see whether it makes any difference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste layout.css.font-visibility and pause while the list is filtered

Note: before Firefox 94

(3) Double-click the layout.css.font-visibility.level preference (or click the pencil button) to display an editing field, and choose a lower value, then press Enter or click the blue check mark button to save the change.

Note: starting in Firefox 94

(3) Double-click the layout.css.font-visibility.standard preference (or click the pencil button) to display an editing field, and choose a lower value, then press Enter or click the blue check mark button to save the change.

Any difference on Github? The values for this preference mean:

  • 1 - only use base system fonts
  • 2 - also use fonts from optional language packs
  • 3 - also use user-installed fonts

Geändert am von jscher2000 - Support Volunteer

more options

jscher2000 said

body { font-family: -apple-system,BlinkMacSystemFont,Segoe UI,Helvetica,Arial,sans-serif,Apple Color Emoji,Segoe UI Emoji; }

Not totally related : it happen on https://extensions.sondages.pro/ If there are Helvetica before sans-serif : Helvetica is choosen.

If i remove helvetica from the list : Sans-serif default from Gnome is used (Liberation)

Are you sure you don't have Helvetica installed?
100% sure ! Debian 10 buster from yesterday.
There is a preference intended to limit fonts used by pages if you don't want "user installed" fonts to be used. You could try this and see whether it makes any difference:
It's not want or not : No Helvetica => no reason to use helvetica.

I have the same value on ESR and 89 (on same computer).

I have an account on https://bugzilla.mozilla.org/index.cgi, i really think it's an issue here.

Geändert am von Shnoulle

more options

jscher2000 said

body { font-family: -apple-system,BlinkMacSystemFont,Segoe UI,Helvetica,Arial,sans-serif,Apple Color Emoji,Segoe UI Emoji; }

Not totally related : same issue on https://extensions.sondages.pro/

If i remove manually (via F12/ edit css) Helvetica from the list : Liberation is used (seems to come from my Gnome theme)

Are you sure you don't have Helvetica installed?
100% sure (and screenshit clezrly show it's broken)
There is a preference intended to limit fonts used by pages if you don't want "user installed" fonts to be used. You could try this and see whether it makes any difference:

I have 3 on 89 and on ESR (78) : OK in ESR, not OK in 89.

I have an account on https://bugzilla.mozilla.org/ , maybe an issue with Helvetica here.

more options

Ausgewählte Lösung

OK : issue already reported : regression with Firefox 89 : https://bugzilla.mozilla.org/show_bug.cgi?id=1714318