Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Missing Text on Some Web Pages

  • 5 Antworten
  • 1 hat dieses Problem
  • 31 Aufrufe
  • Letzte Antwort von jdlowder

more options

Since the new Firefox update, text has been missing on some web pages. (Image below of https://www.jsonline.com/). Any suggestions for addressing this?

Angefügte Screenshots

Alle Antworten (5)

more options

I refreshed Firefox. No change.

If I run in Troubleshoot Mode, the problem mostly disappears--but the problem returns when I leave Troubleshoot Mode, even with all extensions disabled and themes changed to defaults.



more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window


more options

This could be a problem with the font that is used.

Do you get visible text when you use "Select All" (Ctrl+A) in the right-click context menu.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make changes effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


more options

Additional details:

  • Hardware acceleration turned off: No effect.
  • Cache and cookies cleared. No effect.
  • Enhanced tracking shut off on page with no text: No effect.
  • Right click - Select All on page with missing text: no missing text appears. Blue boxes appear where there are links, but without text in them.
  • Right click - Inspect on page with missing text. Under "Inherited from body" there is a line through "font-family: Helvetica, Arial, sans-serif;" and when I click on "filter rules containing this property, it lists `font-family`

I don't see a way to fix this under Settings > Languages and Appearance > Fonts and Colors > Advanced. The default serif font is (Default) Time New Roman. The default sans-serif is (Default) Arial. I have "Allow pages to choose their own fonts" checked.


more options

Eureka. Unchecking "Allow pages to choose their own fonts" under Settings > Languages and Appearance > Fonts and Colors > Advanced seems to have solved the problem of the missing text. Will continue to check to see if it reoccurs.


Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.