Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

When clicking "open link in new tab" Firefox sometimes opens in new window instead

  • 7 Antworten
  • 1 hat dieses Problem
  • Letzte Antwort von jscher2000

more options

When I open a first Firefox instance from taskbar in Windows 10, if I do a Google search then right click on any of the results, then select "Open Link in New Tab", FF lalways opens that link in a new window, not a new tab as requested. The new window takes up the right hand half of my display which means I have to manually size it larger or maximize it. This behavior continues as long as I use the first FF window to open any links - they never open in a tab of the original window and only create lots of windows - this is very hard to deal with IMHO. Now here's the weird part - If I use one of the new windows, then FF behaves just as it should. Do a Google search and all links can be opened in new tabs in the new window, as requested. I did not notice this strange behavior until about April 10 when I believe I accepted a new update to FF.

Alle Antworten (7)

more options

Indeed its a funny thing, your windows 10 computer seems to have a personality of its own. Its those damn AI, one day they will take over the world and no one can help it.

Hilfreich?

more options

You can try to close the window that isn't working properly and keep using the new window and possibly move tabs to the new window.

Hilfreich?

more options

Is the problem on your home page, for example: https://www.google.com/ is set as your home page, and you search in the first window, first tab, automatically loaded home page?

Or are you running a Google search through the Firefox home page or address bar, and that is the results page with the problem?

Hilfreich?

more options

OK I found that when I start a new FF session, I get a FF logo and a text entry box for searching. If I use that first search box for anything at all, then any links it presents will not give me a new tab, only a new half-window even if I specify Open in New Tab. BUT: if, from the first FF window, I click my shortcut to the Google search engine and use Google for searching, everything behaves as it should. Clicking on links found by Google, they open in new tabs as requested. I found that the search engine in my default home page was Yahoo. Entering text to search for in that first FF window brings up a URL to Yahoo search engine. So something about the links returned by the Yahoo search are causing the inability of FF to obey the request to Open in New Tab. So, easy workaround exists - thanks for the replies.

Hilfreich?

more options

Sounds reasonable, but you shouldn't be stuck with an unwanted home page or search engine, so you could take a look at your add-ons and settings if you need to get that sorted out.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, private search, Yahoo, etc.? Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Hopefully you can regain control!

Hilfreich?

more options

There was a much easier way - just don't use Yahoo as the default search engine. I found the setting in Options to allow setting Google as the default search engine and that seems to have solved the problem. If I still have the problem I'll go into extensions as recommended. Thanks for the help!

Hilfreich?

more options

Hi qtluom, if you get a chance to look it up, what was the name of the unwanted one that gave you Yahoo results? Firefox doesn't come with Yahoo anymore.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.