Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Spelling chek option don't appears in in outlook.office.com with Firefox browser

more options

Dear Mozilla community,

Before I wrote this question, I read a lot of posts but non of them provided answer to my problem, despite I saw some other having similar problem. Here is the problem. I'm using Firefox as browser. When using "outlook.office.com/mail/" (the email of my university) or "outlook.live.com/mail/" (my personal hotmail email), the spelling option and dictionary choices don't appear when I write click on the text field. The consequences are that the spelling check doesn't work. This problem appears only with outlook services. For example, in the text field I'm currently typing in while writing this message, the option does appear (as you can see in the second attached print screen), but when I do the same in outlook, this option don't appears anymore (as you can see in the first attached print screen). As you can see, the contextual options after right clicking on the text field are different and I don't understand why.

I have two dictionaries installed (French and English) and they work perfectly everywhere except in outlook. I read some Microsoft posts about that but what they explain is that the spelling check in outlook is all based on the browser options.

I'm not sure of when this problems append but I know the Firefox spelling check used to work before even in outlook. So I don't know if a update or something else created that but it's very bugging me and I might have to leave Firefox is I can't solve this problem.

If anyone who faced similar problems found a solution, I would be very glad to hear it! Thanks a lot

Gabriel

Angefügte Screenshots

Ausgewählte Lösung

A webpage can disable the Firefox spell checker via a spellcheck="false" attribute of an input field or textarea or editable element and possibly provide its own spelling checker. You can right-click in the text area or input field and use "Inspect Element" to check in the Inspector if this text area has a spellcheck="false" attribute. You can remove this spellcheck="false" attribute or change it to spellcheck="true" via a double-click or via "Edit As HTML" to make the "Check Spelling" item in the right-click context menu reappear. Firefox will disable "Check Spelling" in the right-click context menu of a text area if the web page disables the spelling checker via a spellcheck="false" attribute of this element.


See also:

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (4)

more options

Ausgewählte Lösung

A webpage can disable the Firefox spell checker via a spellcheck="false" attribute of an input field or textarea or editable element and possibly provide its own spelling checker. You can right-click in the text area or input field and use "Inspect Element" to check in the Inspector if this text area has a spellcheck="false" attribute. You can remove this spellcheck="false" attribute or change it to spellcheck="true" via a double-click or via "Edit As HTML" to make the "Check Spelling" item in the right-click context menu reappear. Firefox will disable "Check Spelling" in the right-click context menu of a text area if the web page disables the spelling checker via a spellcheck="false" attribute of this element.


See also:

Hilfreich?

more options

Hi cor-el, Thanks a lot for you reply and helps. I did what you said and it worked!! I had to find three lines of code where spellcheck="false" appeared and I changed them for "true". Then, I closed the HTML window and I was able to see the spelling language option in the right click menu in the outlook text field.

Now my question is, is there a way to fix this option to "true" or will I always have to go to the HTML editor to change that everyday I reopen my computer???

I tried again to look at the option in outlook setting but couldn't find anything... Am I the only one using Firefox and outlook having this problem?

Hilfreich?

more options

Does that website use a plain text editor like in this forum or a rich text editor ?

I posted some JavaScript bookmarklets in this thread that you can try to see if this works.

  • javascript:void(document.activeElement.setAttribute('spellcheck','true'));
  • [/questions/1319676] Spell check not working on some websites and some new features on Facebook

You can possibly show a screenshot that shows the HTML code of this text area in the Inspector.

Hilfreich?

more options

Hi cor-el,

Please excuse the delay in my answer, end of semester exam rush last week... Ok well, after starting my computer, I realized that the modifications I did (those you suggested) are still there so it look like what you suggested solved the problem permanently! :-)

I'm glad I asked on this forum and thank you very much for you very good advice! :-)

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.