Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Link to .docx files no more opened by MS Word

  • 6 Antworten
  • 1 hat dieses Problem
  • 2326 Aufrufe
  • Letzte Antwort von gkerschb

more options

Hello, we have a CVS repository which can be browsed using viewvc. In this repository there are some .docx files which are MS Word documents. Until about one week ago, clicking on such a link brought up a dialog asking what Firefox should do with this file. One of the options is to open it with Word (see image 'ChooseWord').

But now this is no longer possible. I believe it vanished in the course of the automatic Firefox updates. Now the dialog looks like in the attached image 'NoWord'.

How can I restore the old behaviour?

Thanks, gernot

Hello, we have a CVS repository which can be browsed using viewvc. In this repository there are some .docx files which are MS Word documents. Until about one week ago, clicking on such a link brought up a dialog asking what Firefox should do with this file. One of the options is to open it with Word (see image 'ChooseWord'). But now this is no longer possible. I believe it vanished in the course of the automatic Firefox updates. Now the dialog looks like in the attached image 'NoWord'. How can I restore the old behaviour? Thanks, gernot
Angefügte Screenshots

Ausgewählte Lösung

Based on the content-type listed in the second download dialog, Firefox is behaving as designed. It's weird that there is a different content-type listed for the identical file in the two dialogs. I don't know what is causing that.

Firefox has one preference related to overriding the generic binary file type. Does it make any difference if you turn off this preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste octet and pause while the list is filtered

(3) Double-click the pdfjs.handleOctetStream preference to switch the value from true to false


Otherwise, I have an extension that should correct the confusion by replacing the generic binary file content type with the correct one for downloads with a .docx extension. (After installation, turn on the extension by clicking its Zzzz button on the toolbar.)

https://addons.mozilla.org/firefox/addon/content-type-fixer/

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (6)

more options

What do you have here? see screenshot Also, update your browser.

Geändert am von jonzn4SUSE

more options

Hello jonzn4SUSE,

thanks for your reply! Please see screenshot.

At the time of the incident, the browser was at its latest version (84.0.2)

more options

The second screenshot shows that the file is send as a generic content type (application/octet-stream). Firefox will always offer to save Files send this way. The server would have to send this file as a valid content-type for the .docx file extension like probably happens with the file in the first screenshot to make this work properly.

more options

Hello cor-el,

Thanks for the reply!

The second screenshot is from version 84.0.2 after clicking on exactly the same link as done from a version 83 browser yielding the first screenshot. So I would assume the server sent the same data to both broswers. I have attached the Applications screenshot from the 83 version.

more options

Ausgewählte Lösung

Based on the content-type listed in the second download dialog, Firefox is behaving as designed. It's weird that there is a different content-type listed for the identical file in the two dialogs. I don't know what is causing that.

Firefox has one preference related to overriding the generic binary file type. Does it make any difference if you turn off this preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste octet and pause while the list is filtered

(3) Double-click the pdfjs.handleOctetStream preference to switch the value from true to false


Otherwise, I have an extension that should correct the confusion by replacing the generic binary file content type with the correct one for downloads with a .docx extension. (After installation, turn on the extension by clicking its Zzzz button on the toolbar.)

https://addons.mozilla.org/firefox/addon/content-type-fixer/

more options

Hi jscher2000,

thanks for your reply!

Changing the preference as you suggested didn't make a difference but your extension works like magic, straight opened the link into word.

Thank you very much!