Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Printer using system dialog box

  • 37 Antworten
  • 11 haben dieses Problem
  • 4266 Aufrufe
  • Letzte Antwort von chris.com

more options

Apparently Mozilla did an update and not it defaults to it's own printer dialog box. I hate it. There is a link to use the system print dialog box but it only works for that specific print job. I can't find a setting to force Firefox to always use the system printer dialog box. Anyone know how to fix this? It's enough to make me stop using the browser becasue thr Firefox dialog box sucks.

Ausgewählte Lösung

Currently there is a preference to switch back to the old style:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste tab_mo and pause while the list is filtered

(3) Double-click the print.tab_modal.enabled preference to switch between the new experience (true) and the classic experience (false)

(4) If there is another preference named app.normandy.startupRolloutPrefs.print.tab_modal.enabled you can double-click that one to switch it to false as well. If you do not have that one, no need to create it.

Since you are setting to false, it will look roughly like this:

Diese Antwort im Kontext lesen 👍 6

Alle Antworten (20)

more options

contact409 said

Apparently Mozilla did an update and now it defaults to it's own printer dialog box. I hate it. There is a link to use the system print dialog box but it only works for that specific print job. I can't find a setting to force Firefox to always use the system printer dialog box. Anyone know how to fix this? It's enough to make me stop using the browser becasue thr Firefox dialog box sucks.
more options

Ausgewählte Lösung

Currently there is a preference to switch back to the old style:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste tab_mo and pause while the list is filtered

(3) Double-click the print.tab_modal.enabled preference to switch between the new experience (true) and the classic experience (false)

(4) If there is another preference named app.normandy.startupRolloutPrefs.print.tab_modal.enabled you can double-click that one to switch it to false as well. If you do not have that one, no need to create it.

Since you are setting to false, it will look roughly like this:

Geändert am von jscher2000

more options

jscher2000 said

Currently there is a preference to switch back to the old style: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste tab_mo and pause while the list is filtered (3) Double-click the print.tab_modal.enabled preference to switch the value from true to false (you can ignore the other preferences)

Bless you! Thanks very much!

more options

Bless you! Thanks very much!

more options

Thanks for this solution it works. Please Firefox put it back, I use it all the time in the main because I might not be wanting to print all the pages AND/OR because I want to utilise Simplify Page.

Is there a way to access Simpify Page when using the new Firefox print?

BUT really Firefox, you are becoming more and more like Chrome and I hate their iinterface!

more options

jesjaspers said

Is there a way to access Simpify Page when using the new Firefox print?

Currently, there is not. It is on the wish list for a future update.

You can streamline your page view and printout using the Reader View. Since it is more widely spaced for reading, you may need to adjust the line spacing and text size before printing. Here are a couple of screenshots:

more options

jscher2000 said

Currently there is a preference to switch back to the old style: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste tab_mo and pause while the list is filtered (3) Double-click the print.tab_modal.enabled preference to switch the value from true to false (you can ignore the other preferences)

Thank you for this solution (above), it worked for me.

To Mozilla - please change the default back. To provide context for why it's so problematic for me specifically: I print two-sided to save paper. The default in the Mozilla dialog is to print two-sided with the "flip-up" orientation not the much more commonly used "flip-over" orientation. There was no way to change this without opening the printer's dialog box which I had to do with every job, adding multiple steps to every single print job. Now that I have used the solution here to revert to the printer's dialog box, each job initiates using the printer's default settings (print two sided in flip-over orientation) and I don't have to change ANY settings on a per-job basis.

I wouldn't mind the Mozilla dialog so much in place of the printer dialog if I had the ability to change the default settings so that I wasn't forced to make changes to every single print job. But the Mozilla dialog didn't seem to offer that option.

more options

jessica.l.jones said

I print two-sided to save paper. The default in the Mozilla dialog is to print two-sided with the "flip-up" orientation not the much more commonly used "flip-over" orientation. There was no way to change this without opening the printer's dialog box which I had to do with every job, adding multiple steps to every single print job. Now that I have used the solution here to revert to the printer's dialog box, each job initiates using the printer's default settings (print two sided in flip-over orientation) and I don't have to change ANY settings on a per-job basis.

Sorry about that! Firefox may have stored the wrong binding setting and the solution to fix it is a little obscure. To fix it manually:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste duplex and pause while the list is filtered

Firefox should list the print_duplex value for each printer. Printers you have not yet used in the new print experience will have a weird number that is not on this list:

  • 0 => print single-sided
  • 1 => print double-sided, with long-edge (portrait mode left-right) binding
  • 2 => print double-sided, with short-edge (portrait mode top-bottom) binding

To edit a value, double-click the current value to display an editing field. Change it as you wish, then press Enter or click the blue check mark button to save the change.

Does the correction from 2 to 1 work and does it stick?

more options

I'm using Firefox 86.0.1 for Linux Mint (mint 1.0) (This problem predates this latest update, which obviously didn't fix it.)

contact409 and jscher2000, I kiss the hems of your respective garments.

My version of the problem was a little worse than for contact409. The "use the system print dialog box" option opened the system dialog box, but the print job aborted just the same.

I had two workarounds: (1) From the system dialog box option I could print to file, then print the resulting PDF. (2) Refresh Firefox would temporarily permit me to print from the Firefox dialog box, but the problem would reoccur within the same browser session. I took to using Chrome just for printing, which isn't so much a workaround as a capitulation.

Changing the configuration preferences back to the status quo ante worked. I'm mopping my brow.

jscher2000, when you say Currently there is a preference to switch back to the old style, should that currently make me nervous? I'm not a whiz, so it took me awhile to isolate the problem to Firefox and the update, and another while to stumble on this particular support Q&A. I'd like to think that Mozilla can fix this bug.

Many thanks!

more options

Ch_H said

I'm using Firefox 86.0.1 for Linux Mint (mint 1.0) ... jscher2000, when you say Currently there is a preference to switch back to the old style, should that currently make me nervous? I'm not a whiz, so it took me awhile to isolate the problem to Firefox and the update, and another while to stumble on this particular support Q&A. I'd like to think that Mozilla can fix this bug.

Hi, the developers are trying to squash all the bugs and finalize on the new integrated preview/setup/print approach, so they definitely are collecting information on printer and OS/shell incompatibilities. As a Windows person, I don't know the right questions, but I'll try to get someone to contact you via message on this forum, or you could file a bug describing the print job being aborted on Bugzilla, which would put you directly in touch:

This link preselects "Toolkit" rather than "Firefox" as the focus of the problem:

https://bugzilla.mozilla.org/enter_bug.cgi#h=dupes%7CToolkit

more options

Hi again,

I'll file the bug report---I don't normally keep an eye on the forum, so better to get directly in touch. Thank you for the link. I guess I'll have to reset the preferences in order to recreate the problem, but now that I know my way back, that's okay.

Thank you again, and take care!

more options

contact409 said

Apparently Mozilla did an update and not it defaults to it's own printer dialog box. I hate it. There is a link to use the system print dialog box but it only works for that specific print job. I can't find a setting to force Firefox to always use the system printer dialog box. Anyone know how to fix this? It's enough to make me stop using the browser becasue thr Firefox dialog box sucks.

Yeah, this started a few weeks ago, doing that fix is only temporary and it will switch back to that "in browser" view on the next update. It's very frustrating.

more options

adrianjsc said

Yeah, this started a few weeks ago, doing that fix is only temporary and it will switch back to that "in browser" view on the next update. It's very frustrating.

Do you mean in Firefox 86.0.1? I updated the solution with an additional preference to check for. Maybe that will help.

more options

After applying the first correction, if I click on preferences in the normal print dialog box, I get: Function address 0x000000018007260C caused a protection fault. (exception code 0xc0000005)...

more options

First: this is NOT SOLVED because the value, for some reason, is not permanent!

Second: Please REMOVE this enhancement -- it is unhelpful and does nothing.

Third: all the examples you provide do NOT INCLUDE the browser on MAC!

Fourth: the other MAJOR problem is PERFORMANCE -- the print DIALOG now takes forever to to process any print request!

Geändert am von steve

more options

steve said

First: this is NOT SOLVED because the value, for some reason, is not permanent! Second: Please REMOVE this enhancement -- it is unhelpful and does nothing. Third: all the examples you provide do NOT INCLUDE the browser on MAC! Fourth: the other MAJOR problem is PERFORMANCE -- the print DIALOG now takes forever to to process any print request!

Hi Steve, I know each OS has a different print dialog, but I only have Windows, so I can't give you a screenshot for Mac. At least Firefox's print overlay should look the same across all of the systems.

My understanding is that this approach is the future, so it's helpful to know the problems. Can you file a new bug about the slower printing performance on Mac:

https://bugzilla.mozilla.org/

more options

I'm hesitant to use config. Foxfire needs to fix this with a simple toggle switch on the settings page; or just remove foxfire's print dialog, it's redundant and more complex than the system dialog.

more options

I have the same problem. I don't understand what this is trying to accomplish. I don't see any benefit to Firefox having its own print option which takes away all the options and settings. Just a lot of extra clicks and bad thoughts towards Mozilla every time I have to do this. All it does is add extra steps to use my services. I very rarely print to the printer. I use DevonThink and if I print from the internet I almost always want to use the service "save pdf to DevonThink" which is not available in the Firefox dialog. I could use the clipper but it doesn't format files as consistently as the save to option.

Happy to find this post. I used the about:config on mac and it worked fine. Will see if it lasts.

more options

Thanks contact409 and others. Managed to solve my issue in a few minutes after spending forever looking in all the wrong places - a bit like Eric Morecombe and all the right notes in the wrong places.....

Firefox has a lot that is not very user friendly. If only then can get the act together so we can have a leading product.

more options

I'm repeating myself, but don't want my comment buried and forgotten. I'm hesitant to mess with config. Mozilla needs to fix this with a simple switch in options.

  1. 1
  2. 2