Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox's spellcheck suddenly stopped working, any ideas how to fix it?

more options

This is driving me a bit mad...

A while ago the spellcheck in FF just stopped working. I literally only have a single add blocker installed that I've always used. I've not made any system changes lately beyond installing a few games.

- I have the "check spelling as you type" box checked in the browser options. - I have the English language pack installed from here (The British pack installed currently) - I've opened about:congif in the browser itself and made sure the value for layout.spellcheckDefault is set to 1.

It doesn't work on any site.

Chrome is working fine, but I prefer to use FF.

- I've tried reinstalling. - I've tried unchecking and rechcking the box.

Any ideas where what I should try next?

Any help really appreciated!

Ausgewählte Lösung

Sounds that you installed a languag pack. A language pack contains translations for strings in the user interface. For spellcheck you need a spell check dictionary.


Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can look here for dictionaries:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (4)

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

Hilfreich?

more options

Grammarly for Firefox by Grammarly https://addons.mozilla.org/en-US/firefox/addon/grammarly-1/

Grammarly will help you communicate more effectively. As you type, Grammarly flags mistakes and helps you make sure your messages, documents, and social media posts are clear, mistake-free, and impactful.

Hilfreich?

more options

Ausgewählte Lösung

Sounds that you installed a languag pack. A language pack contains translations for strings in the user interface. For spellcheck you need a spell check dictionary.


Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can look here for dictionaries:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.

Hilfreich?

more options

cor-el said

Sounds that you installed a languag pack. A language pack contains translations for strings in the user interface. For spellcheck you need a spell check dictionary.

This was exactly it. I had put that exact link https://addons.mozilla.org/en-US/firefox/language-tools/ in my post originally (second point where it says "installed from here"), but I must have deleted it by accident when posting.

I had installed a pack from the first column, but not the second.

Did that just now and it fixed the issue entirely.

Thanks very much!

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.