Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox 84.0.1 (64bit) won't load my website

  • 16 Antworten
  • 1 hat dieses Problem
  • 268 Aufrufe
  • Letzte Antwort von admin340

more options

My business website wont load in the latest (84.0.1 - 64bit) version of Firefox for Windows. The previous version -84.0.0 did work. Chrome is just fine and much faster, but my preference is for FF. The home page loads (reluctantly), but manuy o the other pages won't load at all. I have ghostery installed but disabled, but this hasn't been an issue previously, and I have tried it with out this add-in, and it made no difference. I don't want to go to Chrome!

Ausgewählte Lösung

I took another look. In this script file:

https://glow.dance/wp-content/themes/asana/js/script.js?ver=1.8.0

at line 575 you have code that runs when the page loads, and this includes the part that removes the overlay:

$(window).load(function() {
  ...
  /* Preloader */
    $(".loaderWrap").fadeOut(300,function(){
      $(this).remove();
    });
 ...

Strangely, when I visit the theme's demo page (https://highseastudio.com/demo/asana-wp/), I can reload and navigate around and I don't get the problem. So there's something different between the two sites. Not sure what it is.

How important is this fading overlay to your design? If you want to prevent people hitting that white wall, and there's no other solution, you could hide the overlay completely with a style sheet change:

.loaderWrap { display: none !important; }

You can add that using the "Additional CSS" option in the Theme Customizer. More info in this article (something that popped up in a web search):

https://wpengine.com/resources/customize-theme-css/

Diese Antwort im Kontext lesen 👍 2

Alle Antworten (17)

more options

.....

Geändert am von jonzn4SUSE

more options

https://glow.dance

more options

https://glow.dance

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

I use Firefox v54 as my default. Your website loaded without any problem. But when I tried using v84.0.1, the site would not load.

more options

No problem here with loading the website in Firefox 84.0.1.

Note that some of the images are send as WebP images, so if you block (disable) this image type then you won't see much.

Geändert am von cor-el

more options

......

Geändert am von jonzn4SUSE

more options

@cor-el; thanks for the post. I have followed most of the instructions and still some pages don't load. It's seems bizarre that all my customers that might visit my website using Firefox 84.0.1 - 64 bit (I know, it's probably only me!) will now have to clear their cache, or re-load (Shift f5) pages once they upgrade to this version of FF. FredMcD above has the same issue with this version (84.0.1 - 64bit).

Maybe it's the version of FF, rather than the website. Maybe whatever updates that were applied between 84.0.1 - 64bit and 84.0.0 - 64bit be reviewed and rolled back?! I think I will attempt to install the ESR version. [There is just so much stuff embedded in my browser (links to websites, passwords, add-ons) that I fear losing them <sigh>] Try loading www.glow.dance/blog/. It won't reliably load for me, and if it does, I can't load the stories!

more options

FYI; I have installed the ESR version (78.6.0esr(64bit)) which has NOT solved the problem. This page will not load - https://glow.dance/blog/ - I speculate (but I don't know) that whatever changes occurred in 84.0.1 also changed in 78.6.0esr. Consequently, I must now park this browser until (or if) the issue is resolved.

To all those that tested their browsers on my site and displayed that same issue, thanks for the feedback. And for those that didn't have the issue, I'm jealous ;-) !

more options

.....

Geändert am von jonzn4SUSE

more options

Not sure why you want a screen shot of a page not loading but here it is!

more options

picking site performance tools at the top of DDG I discovered some problems for you to fix before throwing stones

tools pingdom

might help you the most

Stop loading third party assets. Host them yourself.

more options

The problem is related to the script that displays and removes (or in this case fails to remove) the loading animation overlay -- specifically, this element:

<div class="loaderWrap">

Behind that spinning arrow overlay, the page has indeed finished rendering and is ready to view, but the script is not getting the message for some reason, which apparently is related to Firefox loading resources from cache instead of rebuilding the page each visit.

When you get some free time (ha ha), could you test whether this problem can be tracked to any of your theme options or the plugins you use in your WordPress site?

more options

@jscher2000. Thanks for identifying that the problem lies with the browser (at least, that is what I think you are saying). I'm not sufficiently skilled at removing theme options, and struggle with the amount of 'stuff' that the template (in my view unnecessarily) loads. I can disable some of the plug-ins, but where to start? (TL:DR following- However, the solution shouldn't be to re-build the website when the browser worked one week, and following an update, it no longer works. I agree that upgrading to an alternative template is probably required from a performance perspective, but I don't have the skills the build a website from scratch, or know one determine how a template will perform, until one has actually purchased it!)

@knowledge is like power, I wasn't aware that I was throwing stones. I was indicating that my website wouldn't load in Firefox after a Firefox software update, and that the same problem wasn't occurring in an alternative browser. I also indicated that Firefox is (was) my preferred browser. I was trying to bring to the attention of someone in support that there may be a problem with the current version of the browser. I suggest if I have the problem, then so do many others. I have also thanked (genuinely) all those that have contributed to the issue. I can't solve the problem (obviously). as mentioned above, I also acknowledge that the Wordpress website and template have inherent issues, but earlier versions of Firefox and current version of Chrome could still display it. However, if this is throwing stones then I'll just retreat back into my hole and find an alternative browser.

Thanks again to all the contributors.

more options

Ausgewählte Lösung

I took another look. In this script file:

https://glow.dance/wp-content/themes/asana/js/script.js?ver=1.8.0

at line 575 you have code that runs when the page loads, and this includes the part that removes the overlay:

$(window).load(function() {
  ...
  /* Preloader */
    $(".loaderWrap").fadeOut(300,function(){
      $(this).remove();
    });
 ...

Strangely, when I visit the theme's demo page (https://highseastudio.com/demo/asana-wp/), I can reload and navigate around and I don't get the problem. So there's something different between the two sites. Not sure what it is.

How important is this fading overlay to your design? If you want to prevent people hitting that white wall, and there's no other solution, you could hide the overlay completely with a style sheet change:

.loaderWrap { display: none !important; }

You can add that using the "Additional CSS" option in the Theme Customizer. More info in this article (something that popped up in a web search):

https://wpengine.com/resources/customize-theme-css/

more options

@jscher2000 Brilliant!!!! I have installed that little piece of code, and the website loads (and loads much, much faster).

I'm not sure on the on-going impact of disabling the display delay, but that fixed the load issue. I also tested the Asana site and as you identified, something is different, just not sure what! Thank you very much for the time you have spent trouble shooting the issue and providing a fix.

Cheers,

more options

Hi @jscher2000

I'm experiencing kind of similar issues with my website ana-dismissed.de. Other thread: https://support.mozilla.org/de/questions/1320665

After reading your answer here I deactivated preloading in the wordpress themes options: https://imgur.com/a/azY2HLS

This lead to loading of the above the fold / viewport website content but other issues occured:

on reload: - headline text animations wont work (maybe a JS related issue?) - click on burger menu does not open actual menu - no content is loaded below the fold

Short video about this: https://imgur.com/a/QW3cQKn

I just also added the custom CSS of @jscher2000:

.loaderWrap { display: none !important; }

But still same issue.