Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Recent Firefox upgrade won't talk to my bank's website

  • 6 Antworten
  • 1 hat dieses Problem
  • 24 Aufrufe
  • Letzte Antwort von stevejq

more options

Firefox upgraded recently to 81.0.2. After the upgrade I can no longer connect to my bank’s web site. Firefox displays this failure message:

Secure Connection Failed An error occurred during a connection to xx.xxxxxxx.com The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.

The bank’s customer-no-service help desk politely advised that their system is working, this is a Firefox problem, check the Firefox browser settings, use another browser.

I am not a browser security settings expert and do not want to be . . . I have no clue as to how to fix this . . . so what do I do?

Can I revert to the previous version of Firefox? How? Thanks.

Ausgewählte Lösung

With Firefox in normal mode, I began disabling extensions one at a time. I found that my problem cleared when I disabled the DuckDuckGo Privacy Essentials extension.

DuckDuckGo Privacy Essentials has a "Permissions" tab in its configuration but I do not see a way to change permissions from the defaults "Access your data for all websites", "Access browser tabs" and "Access browser activity during navigation". So I plan to leave the DuckDuckGo Privacy Essentials extension disabled.

Looks like I am back in business with Firefox and my bank's web site. Appreciate you guiding me through solving this problem.

Steve

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (6)

more options

Hi Steve, does the error page contain a code in caps like SEC_ERROR_SOMETHING ? That could provide more specific information about the nature of the problem.

Does your bank have you install supplemental security software in order to connect? One people have mentioned over the years is IBM Trusteer Rapport. Sometimes updates cause incompatibility between Firefox and that program.

Do you connect through a security suite's special banking browser? Sometimes updates cause incompatibility between Firefox and those features.

As of course, you could use another browser like Microsoft Edge for your banking while we help you sort this out.

Hilfreich?

more options

Thanks jscher2000.

"Hi Steve, does the error page contain a code in caps like SEC_ERROR_SOMETHING ? That could provide more specific information about the nature of the problem." -- No error number, see attached screen shot.

"Does your bank have you install supplemental security software in order to connect? One people have mentioned over the years is IBM Trusteer Rapport. Sometimes updates cause incompatibility between Firefox and that program." -- No.

"Do you connect through a security suite's special banking browser? Sometimes updates cause incompatibility between Firefox and those features." -- Not that I know of, but I do not know what a “security suite's special banking browser” is.

"As of course, you could use another browser like Microsoft Edge for your banking while we help you sort this out." -- I am using Microsoft Edge, it connects to my bank’s web site without issue. I miss Firefox though

Hilfreich?

more options

Hmm, that error page isn't very helpful, is it.

I don't see a problem with the site -- if I try some random banks using search results, my Firefox doesn't object:

https://www.google.com/search?q="cm.netteller.com"

However, perhaps it's possible that different banks have a different configuration?


stevejq said

"Do you connect through a security suite's special banking browser? Sometimes updates cause incompatibility between Firefox and those features." -- Not that I know of, but I do not know what a “security suite's special banking browser” is.

Those would be features with names like Safe Banking that take over the connection or launch a special window.


Could you try clearing Firefox's Web Cache? See: How to clear the Firefox cache. If you have a large hard drive, this might take a few minutes.

If that doesn't help, could you test in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hilfreich?

more options

Cleared the cache, no joy. Same error page as before.

Progress, however, with Safe Mode. Firefox Safe Mode allows the bank web site to load and the site appears to function normally.

Where to from here? Thank you.

Hilfreich?

more options

Generally speaking, the main changes in Firefox's Safe Mode are:

  • Extensions are disabled -- you can check whether any of them affect how Firefox connects
  • Hardware acceleration is disabled -- this normally wouldn't affect the initial connection
  • Optional userChrome.css / userContent.css files are disabled -- these normally wouldn't affect the initial connection
  • JavaScript "Just in time" compilers are disabled -- these normally wouldn't affect the initial connection

Hilfreich?

more options

Ausgewählte Lösung

With Firefox in normal mode, I began disabling extensions one at a time. I found that my problem cleared when I disabled the DuckDuckGo Privacy Essentials extension.

DuckDuckGo Privacy Essentials has a "Permissions" tab in its configuration but I do not see a way to change permissions from the defaults "Access your data for all websites", "Access browser tabs" and "Access browser activity during navigation". So I plan to leave the DuckDuckGo Privacy Essentials extension disabled.

Looks like I am back in business with Firefox and my bank's web site. Appreciate you guiding me through solving this problem.

Steve

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.