Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

A problem with setting a new bookmark

  • 44 Antworten
  • 1 hat dieses Problem
  • 158 Aufrufe
  • Letzte Antwort von reble

more options

I hit bookmark this page and the window opens, 1st screen capture.

https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-09-24-23-47-06-d7aee0.png

Next I expand "other bookmarks" then "choose" See 2nd screen capture

https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-09-24-23-52-08-d9387a.png

When I click on "choose" see what happens in the 3rd screen capture.

https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-09-24-23-54-18-679698.png

I can choose the sub folder to save the bookmark to. BUT I now CAN'T scroll down the screen to hit the save button. Because the bookmark window doesn't have a scroll bar or a way to make the bookmark window smaller. This is frustrating. Firefox is having other issues not connected with this issue. But the overall picture is getting me to the point of dumping Firefox and going to Google Chrome.

Steve

Angefügte Screenshots

Ausgewählte Lösung

Hmm, what if you add the rule to suppress the screenshot and site icon section at the top of the drop-down to the beginning of your userChrome.css file. Do these rules work?

/* Hide Giant Thumbnail and Favicon */
#editBookmarkPanelImage, 
*|div#editBookmarkPanelFaviconContainer {
  display: none !important;
}

(Originally suggested here: https://support.mozilla.org/en-US/questions/1305849#answer-1353063 )

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (20)

more options

I followed the instructions that were in this link https://www.userchrome.org/how-create-userchrome-css.html .

Hilfreich?

more options

I followed the instructions in this link https://www.userchrome.org/how-create-userchrome-css.html . What version of Firefox do you have? Mine is 81.0 (64-bit).

Hilfreich?

more options

It is also possible that I goofed in following the instructions.

Hilfreich?

more options

I have Firefox 81 on Windows. I suppose if the panel is no longer running off the screen it's mission accomplished, but it might be a coincidence. Do you have dual displays at different resolutions? Firefox sometimes miscalculates the heights of drop-down panels in that situation.

Hilfreich?

more options

My 2nd display is in the form of a backup laptop. The Sony laptop is a few years older then the Gateway laptop. But the Sony does what I need it to do. The Sony OS is Win 7 Home 32 bit. The Sony has a multirole. It get's me online when the Gateway is having problems. I use the Sony to display instructions when I am doing something on the Gateway. Like games that require a game walkthrough or a level map and so on.

Hilfreich?

more options

Well I am back to square one. When I opened Firefox just now. The bookmark window is running off the bottom of the page. I am wondering if Firefox is even seen the userChrome.css file

Geändert am von reble

Hilfreich?

more options

This is driving me buggy. userChrome.css just flat out is NOT working. Maybe it is in the wrong dir, I have no clue.

Hilfreich?

more options

Here are the most common issues with setting first userChrome.css file not working:

(A) Location

Firefox looks for the file in a chrome folder in the currently active profile.

(B) File name

If your OS hides file extensions, it's not uncommon to end up with a file named userChrome.css.txt or userChrome.css.css instead of userChrome.css. Firefox is quite particular about this.

You can use the method I mentioned in my earlier reply to generate and download a userChrome.css file if one you created from scratch is not working.

(C) Preference

Older guides (before Firefox 69) didn't include the step of setting Firefox to look for userChrome.css at startup. (#6 in my page)

Hilfreich?

more options

What editor did you use to create the userChrome.css as this file needs to be a plain text file without nay formatting ?

You can try to open this file in a Firefox tab for inspection. You can check the location to see if userChrome.css is in the chrome folder in the current profile folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Hilfreich?

more options

I used Windows notepad to make the file. The file is located in AppData > Roaming > Mozilla > Firefox > profiles > chrome. And the EXE is .css

cor-el said

What editor did you use to create the userChrome.css as this file needs to be a plain text file without nay formatting ? You can try to open this file in a Firefox tab for inspection. You can check the location to see if userChrome.css is in the chrome folder in the current profile folder. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Geändert am von reble

Hilfreich?

more options

reble said

I used Windows notepad to make the file. The file is located in AppData > Roaming > Mozilla > Firefox > profiles > chrome.

The chrome folder needs to be inside the individual profile folder that Firefox is running out of, and not in the Profiles folder above it. It's the first thing you see when you use "Open Folder" from the Troubleshooting Information page. Alphabetically, between bookmarkbackups and crashes, although older profiles may have additional folders:

<center></center>

Hilfreich?

more options

Sorry for the extra post. A very busy and troubling day. I am making the corrections now. I went to "About Profiles"

I checked the Root Directory > C:\Users\Steve\AppData\Roaming\Mozilla\Firefox\Profiles\dz06um9i.default-release. I hit the "open folder" button. The chrome folder is not there.

I checked the Local Directory > C:\Users\Steve\AppData\Local\Mozilla\Firefox\Profiles\dz06um9i.default-release. I hit the "open folder" button. The chrome folder is not there.

As per the instructions that I was following. The userChrome.css file is in C:\Users\Steve\AppData\Roaming\Mozilla\Firefox\Profiles\chrome . Is the "chrome" sub dir in the wrong place?

Geändert am von reble

Hilfreich?

more options

I opened About Profiles. Checked the root dir. The folder is now there and the file is there. But no change in the bookmark problem. Does the folder also have to be in the local dir as well?

Hilfreich?

more options

I have made bat file shortcut files to start MSDOS games running on the Dosbox emulator in notepad. This shouldn't be that much different.

Hilfreich?

more options

Why isn't this working? I did everything that I was spouse to do and moved the folder and file to the right dir. What gives?

Hilfreich?

more options

The chrome folder goes in the root directory:

C:\Users\Steve\AppData\Roaming\Mozilla\Firefox\Profiles\dz06um9i.default-release\chrome

so that covers the first common issue.

Second is file name. I think you've checked that, and Windows should show the file type is either "CSS file" or "Cascading Style Sheet Document" (depending on what various software has put in the Registry). If it shows "Text Document" that is a problem.

Third is making sure you flipped the toolkit.legacyUserProfileCustomizations.stylesheets preference to true in about:config.

Hilfreich?

more options

I checked again just now. The file name is "userChrome.css" I just now pasted in the file name in here. The toolkit.legacyUserProfileCustomizations.stylesheets is set to true. I dbl checked it just now. The bookmark window still goes off the bottom edge when I open the "choose a folder" and there is still no scroll bar. About (depending on what various software has put in the Registry). I don't know what to look for or where in the Windows Registry to look for it. Something is not set right or is missing. PS. When the file was saved. The file type was set to show all files and I manually added the .css on the end of the file name.

jscher2000 said

The chrome folder goes in the root directory: C:\Users\Steve\AppData\Roaming\Mozilla\Firefox\Profiles\dz06um9i.default-release\chrome so that covers the first common issue. Second is file name. I think you've checked that, and Windows should show the file type is either "CSS file" or "Cascading Style Sheet Document" (depending on what various software has put in the Registry). If it shows "Text Document" that is a problem. Third is making sure you flipped the toolkit.legacyUserProfileCustomizations.stylesheets preference to true in about:config.

Geändert am von reble

Hilfreich?

more options

Ausgewählte Lösung

Hmm, what if you add the rule to suppress the screenshot and site icon section at the top of the drop-down to the beginning of your userChrome.css file. Do these rules work?

/* Hide Giant Thumbnail and Favicon */
#editBookmarkPanelImage, 
*|div#editBookmarkPanelFaviconContainer {
  display: none !important;
}

(Originally suggested here: https://support.mozilla.org/en-US/questions/1305849#answer-1353063 )

Geändert am von jscher2000

Hilfreich?

more options

BINGO!!!!!!

/* Hide Giant Thumbnail and Favicon */
#editBookmarkPanelImage, 
*|div#editBookmarkPanelFaviconContainer {
  display: none !important;
}

</blockquote>

That worked. So that tells me that Firefox is seeing the "userChrome.css" file and the settings are correct. I still wonder why the scroll bar string doesn't work.

jscher2000 said

Hmm, what if you add the rule to suppress the screenshot and site icon section at the top of the drop-down to the beginning of your userChrome.css file. Do these rules work?
/* Hide Giant Thumbnail and Favicon */
#editBookmarkPanelImage, 
*|div#editBookmarkPanelFaviconContainer {
  display: none !important;
}

Geändert am von reble

Hilfreich?

more options

I don't know. I am a fixer of things. I am a newbe when it comes to programming. I can follow instructions and past lines in. But to understand how the strings work to modify the string, not very likely. It took me months to get those MSDOS bat files working right. Here is just one of those bat files.

c:\dosbox\dosbox.exe -c "cycles auto" -c "mount c c:\games" -c "c:" -c "cd dgames" -c "cd menace" -c "bmenace1.exe"

jscher2000 said

Hmm, that's strange. Setting overflow-y:scroll definitely should force a scrollbar, but I can only test on my own Firefox so perhaps I overlooked something?

Hilfreich?

  1. 1
  2. 2
  3. 3
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.