Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Completely disable Firefox update on Ubuntu

  • 2 Antworten
  • 1 hat dieses Problem
  • 2073 Aufrufe
  • Letzte Antwort von FredMcD

more options

I am using Firefox on an old Ubuntu machine, and found myself unable to disable the auto update feature of Firefox. I understand why Firefox wants to do auto update, but for me personally it's negatively impacting my productivity. Many times I was looking up reference materials only to be told that I need to restart Firefox because it just updated itself. Imagine how frustrating it is, especially when I use the Private Browsing mode a lot to avoid having to clean up browsing history and cached files later. All in all, while the auto update feature might be good for some users, it's just not working for me, so I want it to be disabled.

I tried a couple of things. First, there's nothing in the "Preferences" page related to the auto update. Second, I tried to change the value of "app.update.auto" in the "about:config" page to false, and it still does auto update. Finally, I tried to add a "policies.json" file to "/etc/firefox/", with the following content:

{ "policies":

  {
    "AppAutoUpdate": false,
    "DisableAppUpdate": true,
    "DisableTelemetry": true
   }

}

Yet it still does auto updates. As a matter of fact, it updated itself to version 80 just now. This driving me crazy. Any useful suggestions will be sincerely appreciated.

I am using Firefox on an old Ubuntu machine, and found myself unable to disable the auto update feature of Firefox. I understand why Firefox wants to do auto update, but for me personally it's negatively impacting my productivity. Many times I was looking up reference materials only to be told that I need to restart Firefox because it just updated itself. Imagine how frustrating it is, especially when I use the Private Browsing mode a lot to avoid having to clean up browsing history and cached files later. All in all, while the auto update feature might be good for some users, it's just not working for me, so I want it to be disabled. I tried a couple of things. First, there's nothing in the "Preferences" page related to the auto update. Second, I tried to change the value of "app.update.auto" in the "about:config" page to false, and it still does auto update. Finally, I tried to add a "policies.json" file to "/etc/firefox/", with the following content: { "policies": { "AppAutoUpdate": false, "DisableAppUpdate": true, "DisableTelemetry": true } } Yet it still does auto updates. As a matter of fact, it updated itself to version 80 just now. This driving me crazy. Any useful suggestions will be sincerely appreciated.

Ausgewählte Lösung

I might have found the solution to this. Instead of using the Ubuntu version of Firefox from Canonical, I downloaded Firefox 80 directly from Mozilla and now point "/usr/bin/firefox" to the official Mozilla version. You might need to use the profile manager to choose the existing profile, in case the Mozilla version of Firefox created a new one somehow. Now there is a "Check for updates but let you choose to install them" option in the "Preferences" page. Hopefully Firefox will no longer update itself after this.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (2)

more options

Ausgewählte Lösung

I might have found the solution to this. Instead of using the Ubuntu version of Firefox from Canonical, I downloaded Firefox 80 directly from Mozilla and now point "/usr/bin/firefox" to the official Mozilla version. You might need to use the profile manager to choose the existing profile, in case the Mozilla version of Firefox created a new one somehow. Now there is a "Check for updates but let you choose to install them" option in the "Preferences" page. Hopefully Firefox will no longer update itself after this.

Geändert am von dev.1one.w01f

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.


How do you completely turn off update checks in Firefox v64? You can use a policies.json file to disable updates for all users. https://github.com/mozilla/policy-templates/blob/master/README.md or https://winaero.com/blog/disable-updates-firefox-63-above/

You can use a policies.json file in the distribution folder in the Firefox installation folder instead as also listed in the article, so no need to use GPO keys in the Windows Registry. • https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson