Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Devtools Network Params Tab is missing

  • 3 Antworten
  • 1 hat dieses Problem
  • 12 Aufrufe
  • Letzte Antwort von peekolo

more options

Hi,

I am on a MacOS Firefox v79.0 16 bit and I used to have the Params tab in the Network section of the Developer Tools that shows the GET/POST parameters.

It suddenly went missing after some update this year. May I know how can I get it back?

Angefügte Screenshots

Alle Antworten (3)

more options

The Request panel shown in your screenshot shows POST params for me on my test login page (just put any text for the credentials):

https://www.jeffersonscher.com/res/logintest.html

If there are some cases where it doesn't work, I suggest alerting the DevTools team on their forum over here:

https://discourse.mozilla.org/c/devtools

It does not seem to show GET parameters, which would be useful.

Hilfreich?

more options

Thanks for the response. I have narrowed down the issue. I'm using a service worker and it seems that Firefox does not show the POST (formdata) parameters for cached pages, which should not be the case since POST data cannot be cached. Chrome shows the parameters regardless of the service worker and I think that should be the expected behavior.

Hilfreich?

more options

Posting a follow up in case anybody else encounters this and searches for a solution. Mozilla's dev team has responded that it is a bug and they are in the process of fixing it. https://bugzilla.mozilla.org/show_bug.cgi?id=1653743

Thanks!

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.