Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox 78 and the webp file extension for images. How do I disable webp?

  • 6 Antworten
  • 1 hat dieses Problem
  • 114 Aufrufe
  • Letzte Antwort von SABUNCU

more options

I'd like it if Firefox would automatically convert webp images to jpg or png files instead of the opposite... stop trying to save png or jpg files as webp... and stop serving me webp images when it is optional. I understand there are websites that ONLY display webp format images, but I am also aware that jpg and png files exist on many of these websites as well. I do not want to disable the ability to display webp in the browser, but I want to turn off whatever option is currently turned on.

I'd like to go back to being able to right click, Save Image As > and end up saving a png or jpg. There have been several websites over the last few weeks that I have visited, and even if the image in the URL is named jpg or png, Firefox tries to save it as a webp. This is complicating my image saving process. I am using the Add-on named "Save webP as PNG or JPEG" which works, but slows down my saving process considerably. The Add-on does not remember the last folder I saved an image to, and adds several additional clicks to what used to be a simple process.

Is there a way in about:config to prevent Firefox from putting webp as the default file format in the Save Image As dialog box?

Suggesting that I use Internet Explorer or Edge is crazy. I'm not changing browsers.

You can demo this annoyance by trying to save this image, which is obviously supposed to be a jpg: https://media.entertainmentearth.com/assets/images/7c23e8c9a6014c57aa8f5d3e281b3834lg.jpg

Ausgewählte Lösung

Hi brandon9, what is happening on a lot of sites is that the server checks whether the browser indicates support for webP and, if they see that, they compress the image in a webP container on the fly without changing the URL or file name. Firefox may recognize that this is a webP image -- if you hover the tab or check the title bar on a stand-alone image in a new tab, Firefox will indicate it there -- but Firefox does not have a converter built in to save back in the original format.

I understand the limitations of my "Save webP..." extension and need to work on it when I get some time, but for now, could I suggest adding a different extension: what this one does is stop Firefox telling sites it would be happy to receive a webP format. That doesn't prevent sites from sending webP images, but it stops most of them from changing formats on the fly (based on tests using URLs from other threads).

https://addons.mozilla.org/firefox/addon/dont-accept-webp/

Diese Antwort im Kontext lesen 👍 3

Alle Antworten (6)

more options

Ausgewählte Lösung

Hi brandon9, what is happening on a lot of sites is that the server checks whether the browser indicates support for webP and, if they see that, they compress the image in a webP container on the fly without changing the URL or file name. Firefox may recognize that this is a webP image -- if you hover the tab or check the title bar on a stand-alone image in a new tab, Firefox will indicate it there -- but Firefox does not have a converter built in to save back in the original format.

I understand the limitations of my "Save webP..." extension and need to work on it when I get some time, but for now, could I suggest adding a different extension: what this one does is stop Firefox telling sites it would be happy to receive a webP format. That doesn't prevent sites from sending webP images, but it stops most of them from changing formats on the fly (based on tests using URLs from other threads).

https://addons.mozilla.org/firefox/addon/dont-accept-webp/

Hilfreich?

more options

Thank you. The add-on "Don't "Accept" image/webp" seams to solve the problem. Hopefully in a future release, Mozilla will add an option so we don't have to rely on an add-on to fix the issue. :)

Hilfreich?

more options

man I cannot believe how dumb mozilla is sometimes. stupid things like this make me want to ditch it completely.

Hilfreich?

more options

Alternatively you can go to about:config and just turn off image.webp.enabled instead of installing an add-on. I had the same issue and easily fixed it in the configuration settings.

Hilfreich?

more options

There's an extension called WebP Image Converter that allows you to specify what you want an image (such as with a .webp file type) to be saved as. It's not foolproof, but it is very useful. https://addons.mozilla.org/en-US/firefox/addon/webp-image-converter/

Hilfreich?

more options

jscher2000 said

... could I suggest adding a different extension: what this one does is stop Firefox telling sites it would be happy to receive a webP format. That doesn't prevent sites from sending webP images, but it stops most of them from changing formats on the fly (based on tests using URLs from other threads). https://addons.mozilla.org/firefox/addon/dont-accept-webp/

The extension you referenced is *so* useful; thank you so much. No wonder you're a top-10 contributor! Without this extension, New York Times images default to webp, which I don't care for. Thanks again.

Geändert am von SABUNCU

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.