Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

The printer control page on my local network is blocked because of certificate error.

  • 3 Antworten
  • 1 hat dieses Problem
  • 81 Aufrufe
  • Letzte Antwort von groost

more options

The control page of my locally connected printer at 192.168.1.5 is being blocked as a "dangerous" site because it doesn't have a valid certificate as a web site. It's literally RIGHT NEXT TO MY COMPUTER! No path to the public internet is involved! How can I make this an exception (i.e. a "trusted site") to the certificate error blocking routine? I don't want to drop certificate checking for OUTSIDE web pages, just the one that controls my printer (the same IP address is accessible for printing and scanning, but not for editing my printer's options).

The frame for the printer's home page displays but with no data, and no data is displayed when anything is clicked. I've tried to add a screen shot but it doesn't upload.

Ausgewählte Lösung

It sounds like maybe your printer is trying to force to you connect using HTTPS, but it doesn't actually have an SSL certificate on it. Try manually typing in http://192.168.1.5 to force Firefox to connect via HTTP instead.

Hope this helps.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (3)

more options

Ausgewählte Lösung

It sounds like maybe your printer is trying to force to you connect using HTTPS, but it doesn't actually have an SSL certificate on it. Try manually typing in http://192.168.1.5 to force Firefox to connect via HTTP instead.

Hope this helps.

Hilfreich?

more options

That did help, but it took two tries. The browser automatically inserts (or changes) the prefix of the URL to "https://" and blocks it, but I can edit the address bar to change it back to "http://" and allow access.

Same thing with the router's web page, which also has an internally defined name "http://routerlogin.net" and opens up with one pass through the security (after entering a username and password on a popup window). The home page also switches to "https" when navigating to an individual page. In this case, the security warning also pops up, but allows an override.

I can see the logic, in that the browser's protection addon doesn't know the difference between public and local network address (although if it begins with 192. that's a clue!), and a public web page could use "http" instead of "https." And (maybe) it learns after the first override for each page address. I do know it takes longer to populate when the security is bypassed.

The printer control page "http://192.168.1.132" has been "learned." The router must be accessed through "http://routerlogin.net." But they both work now. Thanks for that suggestion!

Hilfreich?

more options

My older Samsung printer also runs a web server at its LAN address for administering it.

I've always been able to login from other computers on my local network to check toner, see page counts, and so on.

There is no "force Firefox [v. 82] to connect via HTTP" in my case.

Every single attempt to access http://192.168.0.100 is rewritten by the browser to https://192.168.0.100 which I gather requires a certificate to be presented--which the old printer does not offer--after which Firefox declares "Try again."

FF Fanboy from day 1.

Not happy with current behavior. Would love a way out of this hole.

Thank you.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.