Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Yahoo has hijacked my search function

  • 6 Antworten
  • 1 hat dieses Problem
  • 92 Aufrufe
  • Letzte Antwort von dmm312

more options

Today, when I went to use Google, both the search bar and the address bar had been hijacked by Yahoo. Steps I took: 1. checked to make sure Google had been selected (it had) 2. cleared all cache and history and rebooted (didn't help) 3. Ran Malware Bytes (found nothing) 4. deleted Firefox from my computer and downloaded a fresh version (didn't help) 5. searched for suspicious applications, etc. on my hard drive

At this point, I became suspicious of Enhanced Tracking Protection, but I can't turn it off because I cannot locate either Options or Menu. I remain suspicious that ETP is what is causing this issue, but welcome any insight.

Ausgewählte Lösung

Hi Diane, is this problem on your Mac? The reason I ask is that your question ended up under iOS (iPhone/iPad) but the way you describe it definitely sounds more like a desktop OS (Mac/Windows/Linux).

If you are typing in the address bar and the top line of the drop-down says Search with Google, but then you get results on Yahoo, that kind of hijack could be caused by an add-on. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, privacy, or incognito? Anything that looks suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (6)

more options

Ausgewählte Lösung

Hi Diane, is this problem on your Mac? The reason I ask is that your question ended up under iOS (iPhone/iPad) but the way you describe it definitely sounds more like a desktop OS (Mac/Windows/Linux).

If you are typing in the address bar and the top line of the drop-down says Search with Google, but then you get results on Yahoo, that kind of hijack could be caused by an add-on. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, privacy, or incognito? Anything that looks suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

Hilfreich?

more options

Sorry for ending up on the IOS page.

I had disabled my usual add-ons earlier and *hadn't even noticed* that there was a mystery add-on there. Sure enough, that was the culprit--thanks!

Hilfreich?

more options

No worries and thanks for reporting back.

Hilfreich?

more options

Whatever has hijacked my search has also hijacked the addons page. I can't get anything but a blank page whenever I try to go to addons. I'm really getting sick of this but no virus/malware program finds anything. Win 10

Hilfreich?

more options

Hi knappschiles, you need to restart Firefox in its Safe Mode to prevent extensions from interfering with your use of Firefox. Then you should be able to ruthlessly clean up your add-ons. Here's how:

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Try disabling all the extensions that do not have the trophy icon indicating they have been reviewed in the Recommended program. Of course, remove anything you don't need or don't recognize.

Hilfreich?

more options

Thanks Mr. Scher. It may have been javascript or Cisco webex.

Geändert am von dmm312

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.