Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website icons are displayed as white boxes

  • 8 Antworten
  • 1 hat dieses Problem
  • 86 Aufrufe
  • Letzte Antwort von Rocket

more options

I have a problem that occurs on most websites that use icons. All icons show up as blank white boxes, including Google Maps and Wunderground Map. I've attached a screenshot of Wundermap below as an example. I assume its due to some sort of security setting, but I'm not sure which one.

My extensions are DarkReader, uBlock Origin, HTTPS everywhere, and Privacy Badger, but the problem persists even when I disable all of those extensions.

Angefügte Screenshots

Ausgewählte Lösung

Rocket said

jscher2000 said

Are you using the Extended Service Release of Firefox 68? Or a newer version of Firefox with privacy.resistFingerprinting turned on, so Firefox is lying about your version?

I am not using ESR. Currently on release 76.0.1 (64-bit).

Okay, you might try turning off privacy.resistFingerprinting and see whether that makes any difference.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (8)

more options

Do you have the Allow pages to choose their own fonts, instead of your selections above checked in the options of Firefox? Often websites create a custom font as a more efficient way to handle icons instead of using images of them. Unchecking that option in the settings will prevent the website from accessing that custom font.

To see the setting that I'm referring to, go to the Firefox options, scroll down to the Fonts and Colors section of the General section and press the Advanced... button.

Hope this helps.

Hilfreich?

more options

Yeah, that option is enabled already. Thanks for the tip, though.

Hilfreich?

more options

Any relevant messages in the Web Console ?

Hilfreich?

more options

Nothing that jumps out at me:

Request to access cookie or storage on “<URL>” was blocked because it came from a tracker and content blocking is enabled. 2 Loading failed for the <script> with source “https://nebula-cdn.kampyle.com/we/178135/onsite/embed.js”. wundermap:1:1 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://weather.com/api/v1/content-config/ads?positions=WX_W…n&screenSize=desktop&apiKey=5c241d89f91274015a577e3e17d43370. (Reason: CORS request did not succeed).

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://weather.com/api/v1/content-config/ad-third-party?tok…u&screenSize=desktop&apiKey=5c241d89f91274015a577e3e17d43370. (Reason: CORS request did not succeed).

Loading failed for the <script> with source “https://securepubads.g.doubleclick.net/tag/js/gpt.js”. wundermap:1:1 This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”. wundermap:64:16536 Blocked https://www.wunderground.com/wundermap from extracting canvas data because no user input was detected. wundermap:218:22 WebGL warning: texImage: Alpha-premult and y-flip are deprecated for non-DOM-Element uploads. 22-es2015.782f51480cf76fd161dd.js:1:304808 WebGL warning: texImage: Alpha-premult and y-flip are deprecated for non-DOM-Element uploads. 3 22-es2015.782f51480cf76fd161dd.js:1:304808 WebGL warning: texImage: Alpha-premult and y-flip are deprecated for non-DOM-Element uploads. 22-es2015.782f51480cf76fd161dd.js:1:304808 WebGL warning: texImage: Alpha-premult and y-flip are deprecated for non-DOM-Element uploads. 22-es2015.782f51480cf76fd161dd.js:1:304808 WebGL warning: texImage: Alpha-premult and y-flip are deprecated for non-DOM-Element uploads. 2 22-es2015.782f51480cf76fd161dd.js:1:304808 Loading failed for the <script> with source “https://js-agent.newrelic.com/nr-spa-1071.min.js”. wundermap:1:1 Blocked https://www.wunderground.com/wundermap from extracting canvas data because no user input was detected. wundermap:218:22 WebGL warning: texImage: Alpha-premult and y-flip are deprecated for non-DOM-Element uploads. 22-es2015.782f51480cf76fd161dd.js:1:304808 Blocked https://www.wunderground.com/wundermap from extracting canvas data because no user input was detected. 8 wundermap:218:22 WebGL warning: texImage: Alpha-premult and y-flip are deprecated for non-DOM-Element uploads. 6 22-es2015.782f51480cf76fd161dd.js:1:304808 WebGL warning: texImage: Alpha-premult and y-flip are deprecated for non-DOM-Element uploads. 17 22-es2015.782f51480cf76fd161dd.js:1:304808 WebGL: No further warnings will be reported for this WebGL context. (already reported 32 warnings)

Hilfreich?

more options

Are you using the Extended Service Release of Firefox 68?

Or a newer version of Firefox with privacy.resistFingerprinting turned on, so Firefox is lying about your version?

Hilfreich?

more options

I am not using ESR. Currently on release 76.0.1 (64-bit).

Hilfreich?

more options

Ausgewählte Lösung

Rocket said

jscher2000 said

Are you using the Extended Service Release of Firefox 68? Or a newer version of Firefox with privacy.resistFingerprinting turned on, so Firefox is lying about your version?

I am not using ESR. Currently on release 76.0.1 (64-bit).

Okay, you might try turning off privacy.resistFingerprinting and see whether that makes any difference.

Hilfreich?

more options

jscher2000 said

Rocket said

jscher2000 said

Are you using the Extended Service Release of Firefox 68? Or a newer version of Firefox with privacy.resistFingerprinting turned on, so Firefox is lying about your version?

I am not using ESR. Currently on release 76.0.1 (64-bit).

Okay, you might try turning off privacy.resistFingerprinting and see whether that makes any difference.

That fixed it, which is nice but it's unfortunate that I have to have that setting off to fix it. Thank you!

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.