Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How do I revert back to original address bar?

  • 10 Antworten
  • 2 haben dieses Problem
  • 995 Aufrufe
  • Letzte Antwort von Tiger

more options

This last update forcefully added expandable box when you type something in the address bar. I dont like it and want to change it back. Can someone tell me what is the About:config option that I need to toggle to change this?

Ausgewählte Lösung

I have found a solution on reddit that is working . There is only one issue with this. It disables all URL bar suggestions outright but like I said that atrocious enlarged ugly thing is gone

1 . Open about:config and Accept the Risk and Continue.

2. Paste browser.urlbar.disableExtendForTests and create a new Boolean and leave it True.

3. Paste browser.urlbar.maxRichResults and set the value to 0.

4. Restart Firefox.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (10)

more options

Hello Tiger,

Would you do this please :

Type in the address bar about:config and press Enter. (ignore the warning)

Type in the search bar and look for the preference :

browser.urlbar.openViewOnFocus

and set its value to false

Do the same with these preferences :

browser.urlbar.update1

browser.urlbar.update1.interventions

browser.urlbar.update1.searchTips

Then close and restart Firefox.

'Hope this works for you.

more options

Solved! Thank you very much

more options

Tiger said

Solved! Thank you very much

My pleasure, Tiger !

There is a "but", though : this seems to be a temporary fix (so I'm told), but I'm hoping that they will come to their senses .....

more options

McCoy said

Tiger said
Solved! Thank you very much

My pleasure, Tiger !

There is a "but", though : this seems to be a temporary fix (so I'm told), but I'm hoping that they will come to their senses .....

Hey its me again. Seems like they didnt come to their senses afterall :( I am running 77.0 and seems like even with those flags set to false URL bar is popping out. Any idea how to fix this again?

more options

Hello again Tiger,

Would you please take a look at this ghacks article and scroll down to the section :

"A second option, one that will resolve most of the changes even if Mozilla removes the preferences listed above, is to make modifications using a userChrome.css file. "

https://www.ghacks.net/2020/04/08/how-to-restore-the-old-firefox-address-bar/

Any good ?

more options

Yes that did it. Thank you so much! I also went to the bugzilla and I will actively check the posts that address this issue. Really unfortunate we had to resolve to such "hacks" to fix such a trivial issue.

more options

With version 77 I had to resort to the UserChrome.css change. Seriously what the hell is that change for? That simply looks bloody awful! Who was the UI designer that thought this was a good idea? Did he have a stroke?

more options

Tiger said

Really unfortunate we had to resolve to such "hacks" to fix such a trivial issue.

      I know it's a cliché,   but :   I couldn't agree with you more !

more options

So today I load up the internet and what do I see? The unsightly addressbar has returned! So I get on it to change it back as fast as I can...

I've tried the old method (which I've been using ever since this infernal change was made) and the setting are already set to false - thus making that little trick worthless.

I've tried doing that userChrome thing, but as I'm pretty rotten when it comes to computer stuff, I'm fairly certain I did something wrong. I followed the guide pretty much to the letter I think and still the old address bar was not there and whatever it is they are telling me is foreign and hard to understand. I tried copying what it gave me after selecting the options, and even just copied something someone else had done on Reddit, but alas.

Please, I just want my old bar back with the little downward arrow that shows my most visited (I think), as well as not enlarging and doing whatever other new thing it does.

more options

Ausgewählte Lösung

I have found a solution on reddit that is working . There is only one issue with this. It disables all URL bar suggestions outright but like I said that atrocious enlarged ugly thing is gone

1 . Open about:config and Accept the Risk and Continue.

2. Paste browser.urlbar.disableExtendForTests and create a new Boolean and leave it True.

3. Paste browser.urlbar.maxRichResults and set the value to 0.

4. Restart Firefox.

Geändert am von Tiger