Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"already running" message when I click on links in documents

  • 16 Antworten
  • 2 haben dieses Problem
  • 21 Aufrufe
  • Letzte Antwort von Timtak

more options

I used to have two profiles. I deleted one. But I still got profile manager first when starting FF. So I clicked the box to load the default without asking. I'm almost sure that it was immediately after that, when clicking on links elsewhere (e.g. shortcuts I've created, links in pdfs) I get the "FF is already running message." So I manually opened profile manager and unclicked the "use selected profile without asking" button (and I've gone back and confirmed its unchecked) and I'm still getting the message.

Alle Antworten (16)

more options

Firefox should direct external links to open in your default profile. With Firefox closed, if you submit this using the Windows 10 system search box (usually on the Taskbar) does it start your normal profile?

C:\Program Files\Mozilla Firefox\firefox.exe

Regarding the error:

Could you check the icon you use to start Firefox and make sure it does NOT have the following command-line switch in the "Target" box:

-no-remote

Hilfreich?

more options

Thanks for responding. That switch is not in the target.

When I run firefox per your directions, it brings up the box to choose my profile. Only one profile is shown – default. That is why I recently checked the “use selected profile” box, since there seemed no point in choosing when there was only one choice. I am nearly sure that it was right after I checked that box that the problem started. Then I unchecked that box, but the problem remains. I should note that since unchecking that box, but then choosing default profile, web sites seem to have forgotten me, as if it were using a different profile. The only reason I don’t want to just delete all profiles and start anew is the hassle of having to remind all sites of my login etc. But if I’m going to have to do that anyway, I may just start over. So your help would be greatly appreciated.

Hilfreich?

more options

Maybe Firefox transparently created a new profile? Could you check whether your stuff is available in a different profile, as follows:

Profile Manager Page

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile and could list many. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile that Firefox is currently using will have this:

This is the profile in use and it cannot be deleted.

Do you have another profile named default or default-longnumber listed on this page? If so, you can check whether it is the one you were using recently by clicking its Launch profile in new browser button.

If it isn't what you want, simply close that new window.

If it IS what you want, back on the about:profiles page, click the Set as default profile button for that profile so Firefox uses it automatically at the next startup.

Any progress so far?

Hilfreich?

more options

Nope, just the one profile, "default," which is also what shows when the profile manager opens when I have that "automatically open" box unchecked. Really appreciate your trying to help.

And it would seem that even if were willing to lose all cookies and remembered passwords, etc., I can't delete this profile, so what the heck do I do? Again, this problem (links bringing up the "ff already running") started just days ago, after I checked that box. But the manager coming up has been going for quite a while. I originally created a second profile, because I wanted to run a legacy version. But that didn't work well, so I deleted the other profile (over a year ago). Then finally noticed that box and checked it, then this problem started, and stayed even after unchecking that box.

Hilfreich?

more options

Let's not delete, let's add:

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like March2020, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as Default Profile button. Then in the upper right, use the Restart normally button to exit this profile and start up in the other one. This should refresh Firefox's settings files so that all pointers are to this new profile.

Does that work?

If so, you then could go back to about:profiles and set the default profile as default and see whether that works again.

Hilfreich?

more options

I appreciate the very explicit instructions. However, there is not "set as default profile" button below the new profile, only below the preexisting one.

Hilfreich?

more options

zarky1 said

I appreciate the very explicit instructions. However, there is not "set as default profile" button below the new profile, only below the preexisting one.

I guess the page has changed since the last time I tested it. It sounds as though creating the new profile automatically makes the new profile the default so you can skip the step of making it the default.

Hilfreich?

more options

jscher2000 said

I guess the page has changed since the last time I tested it. It sounds as though creating the new profile automatically makes the new profile the default so you can skip the step of making it the default.

(FYI) It changed in fx67 (bug 1556603). I just found out myself and updated the Profile Manager article last month.

Hilfreich?

more options

zarky1 said

I used to have two profiles. I deleted one.

How did you delete it? In the Profile Manager or by manually deleting the profile folder in Windows Explorer?

I'm guessing your manually deleted the profile folder for your default profile and Firefox still thinks it exists. In any case, try creating a new profile like jscher2000 said, which will become the default. You should then be able to go back and set your old profile as the default.

Hilfreich?

more options

Here's what happened. I clicked the Restart normally button. I then clicked on a link. Nothing happened with several links (nothing, not ff running or the link opening or anything). I restarted ff and got the choice of profiles. I chose my old default. Now, when I click on a link, it doesn't open the tab, I don't get the ff running message, instead, it tries to open a new instance and I get the profile manager again. Auuggghhh!!! I really need to be able to click on links. I'm perfectly willing to start totally afresh, if there's a way to do that, and reinstall all pwds etc; that will be less work than what I'm going through (and I do appreciate all you're going through with me). So then I clicked on a link, used profile manager to open the new profile, clicked on another link and it successfully opened in the new one. So then I tried using profile manager to tell the new profile to load w/o asking. Then clicking on a link got me the ff running message. So I accessed profile manager with the –p switch and unchecked that. Now things seem to be working. I’ll just manually chose the new profile and add back in all my passwords etc. and hope for the best. So unless you have other suggestions, thanks very much for your help.

Hilfreich?

more options

Okay, that didn't solve it after all. I closed ff, reopened it, told it to use the new profile (without the box being checked), and now when I click on links, profile manager is coming up again. Not the ff is running message, but profile manager. And I can't tell it chose the current profile because it then says it's already running. All I want (recognizing this isn't like being poor, but still) is to be able to click on links and have them open in a new tab, rather than having to copy them to the address bar (which isn't always possible, with some links- you see only a button, not the link).

So if there is anything you can do to help me, perhaps some way to wipe everything and start like a new user (but still being able to sign in to my ff account, so I can share across devices) I would SO appreciateit.

Hilfreich?

more options

I don't understand your startup sequence. Does your Firefox shortcut call the profile manager? That is not helping. Try removing that from your shortcut target.

Hilfreich?

more options

No. Anytime I start FF, I get the profile manager to chose between the two profiles (the default I had, and the one you had me set up). I'm not asking it to come up; I assumed it comes up automatically if there is more than one profile (unless one checks the box about starting with a particular one, which, as described above, started this whole problem). And then, when I click on a link, any link, it brings up profile manager, regardless of which profile is running.

Hilfreich?

more options

Let's remove two settings files and let Firefox regenerate them and see whether we can get things working normally again.

First, please set Windows to show all file extensions: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Next, use this shortcut path to access the Firefox folder -- you can paste this into the Windows 10 search box on the Taskbar (or into the Windows Run dialog) and execute it there. Windows should open a File Explorer window to the relevant folder:

%APPDATA%\Mozilla\Firefox

Among other things, this folder should contain two INI files:

  • installs.ini
  • profiles.ini

At this point, shut down Firefox and rename those two files:

  • right-click installs.ini > Rename to installsOLD.ini
  • right-click profiles.ini > Rename to profilesOLD.ini

When you start Firefox, it should notice that these files are missing, survey available profile folders, and ask you which one you want to use going forward. If you have the option on whether to do that automatically, turn on doing it automatically.

Any improvement?

Hilfreich?

more options

I got no questions from ff about missing files. It just opened. Then I clicked on a shortcut and this opened a new instance of ff (first installing updates, which the main ff icon did not). I shut them both down. Clicked on ff icon, this time said not default browser (which I had just recently said it should be). I again said it should be. I clicked on a link. It opened a new instance. I closed the first instance. Then another link opened in the remaining instance.

Closed that instance (so no ff running). Opened a new instance with my icon. again asked re default. Closed that. Deleted that icon (thinking maybe something’s wrong with that icon). Opened ff from start menu, same thing (asking re default). Clicked on a link. Again new instance. Again closed both. But I’ve now tried multiple times opening from a shortcut to a particular url, and then things work fine – i.e. links and shortcuts open in same instance with no “ff running” or profile manager (so far, at least). But opening from start menu or an icon created from start menu creates an instance that (a) thinks ff is not default and (b) is ignored when links are clicked. I’m willing to just open it through a shortcut to a url, even if a bit kludgy, if it continues to keep the problem away. On the other hand, if this strange behavior suggests a clean solution to you, great. If not, I’ll live with this kludge (but let you know if problems arise, since earlier things seemed semi-solved, but only for a bit). In either event, I REALLY appreciate the time you have been taking to help me. (One more non-development; since the main icon seemed weird I closed ff, changed name of the new ini files, opened through a shortcut to a url to see if it would ask anything re ini files – it didn’t – and things are the same as just reported, i.e. opening through said shortcut seems to work, while opening through start menu creates an instance that is ignored when clicking on links.)

Hilfreich?

more options

(FIXED) I had the same problem.

I updated to Windows 10 from Windows 7. I am largely amazed that most of my programs mainly work but this does not. Like the OP when I click on a link in email, then I am told that I must close the current Firefox.

I removed parent.lock from my profile folder. The short cut that I am running from my taskbar does not have - no remote in it. I have only the one profile.

But another problem I have is that every time I start up Firefox it tells me it is not the default browser.

Aha, I see I have two instances of Firefox C:\Program Files (x86)\Mozilla Firefox C:\Program Files\Mozilla Firefox

I will uninstall the former (Firefox 47!) and see if that helps.

Yes. That solved the problem. Now when I click on a link in email, it asked me which program i want to use. I chose Firefox and the link opened in this 64 bit Firefox without showing the error message.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.