X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Keyboard input language

Veröffentlicht

Hello everyone. I have weird problem with keyboard input. After my os is booted, i can't switch input language in firefox (I can only write EN keyboard although system input language is RU). Terminal and other progeverything works fine. I have debian 10, kernel 4.19.0-8-amd64. Gnome Shell 3.30.2 Cleaning profile folder didn't help(

Hello everyone. I have weird problem with keyboard input. After my os is booted, i can't switch input language in firefox (I can only write EN keyboard although system input language is RU). Terminal and other progeverything works fine. I have debian 10, kernel 4.19.0-8-amd64. Gnome Shell 3.30.2 Cleaning profile folder didn't help(
Zitieren

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Weitere Informationen

cor-el
  • Top 10 Contributor
  • Moderator
17868 Lösungen 161689 Antworten
Veröffentlicht

How are you changing the input language ? Is that via a keyboard shortcut or via some OS language selector ?

How are you changing the input language ? Is that via a keyboard shortcut or via some OS language selector ?
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

Keyboard shortcut. I googled this problem and I was led to this topic https://www.linuxquestions.org/questions/linux-newbie-8/%5Bmint%5D-firefox-has-a-different-keyboard-layout-than-the-os-itself-4175644537/. That guy had the same problem as I, but there is no solution. And one more thing, switching language works file only after I go to the gnome settings/region and language and change my input sources priority. In that topic somebody proposed to write a script that does it every boot, but I dont think that it's a proper way of solving this problem. Off topic. I'm newbie in linux, so my answers aren't absolutely correct.

Keyboard shortcut. I googled this problem and I was led to this topic https://www.linuxquestions.org/questions/linux-newbie-8/%5Bmint%5D-firefox-has-a-different-keyboard-layout-than-the-os-itself-4175644537/. That guy had the same problem as I, but there is no solution. And one more thing, switching language works file only after I go to the gnome settings/region and language and change my input sources priority. In that topic somebody proposed to write a script that does it every boot, but I dont think that it's a proper way of solving this problem. Off topic. I'm newbie in linux, so my answers aren't absolutely correct.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17868 Lösungen 161689 Antworten
Veröffentlicht

I only use the en-US keyboard layout and if necessary I use the compose key for special (accented) characters.

I only use the en-US keyboard layout and if necessary I use the compose key for special (accented) characters. *https://en.wikipedia.org/wiki/Compose_key *https://fsymbols.com/keyboard/linux/compose/
Hat Ihnen das weitergeholfen?
Zitieren
Veröffentlicht

Fragesteller

Well... I use cyrillic writing script, so it's not my case. ADDED. After some research, I've understood that problem is in my profile.

Well... I use cyrillic writing script, so it's not my case. ADDED. After some research, I've understood that problem is in my profile.

Geändert am von Dmitry

Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.